Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have successfully installed the proprietary drivers for my nvidia (geforce 7300 gt) graphics card on debian/lenny.

I know its not the best way to chose for driver installation ( see this link: http://wiki.debian.org/NvidiaGraphicsDrivers#non-freedrivers ). but the two ways seem to be possible for me (nvidia-kernel module compilation).

Now the problem is that the monitors gets black, the power light starts blinking after i launch the x-server.

Have a short look a the logs (output truncated from /var/log/Xorg.0.log):

    (II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) Jul 28 17:10:11 NVIDIA(0): Enabling RENDER acceleration
(II) Jul 28 17:10:11 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Jul 28 17:10:11 NVIDIA(0):     enabled.
(II) Jul 28 17:10:11 NVIDIA(0): NVIDIA GPU GeForce 7300 GT (G73) at PCI:1:0:0 (GPU-0)
(--) Jul 28 17:10:11 NVIDIA(0): Memory: 262144 kBytes
(--) Jul 28 17:10:11 NVIDIA(0): VideoBIOS: 05.73.22.25.00
(II) Jul 28 17:10:11 NVIDIA(0): Detected PCI Express Link width: 16X
(--) Jul 28 17:10:11 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Jul 28 17:10:11 NVIDIA(0): Connected display device(s) on GeForce 7300 GT at PCI:1:0:0:
(--) Jul 28 17:10:11 NVIDIA(0):     Samsung SyncMaster (CRT-0)
(--) Jul 28 17:10:11 NVIDIA(0):     Samsung SyncMaster (DFP-0)
(--) Jul 28 17:10:11 NVIDIA(0): Samsung SyncMaster (CRT-0): 400.0 MHz maximum pixel clock
(--) Jul 28 17:10:11 NVIDIA(0): Samsung SyncMaster (DFP-0): 165.0 MHz maximum pixel clock
(--) Jul 28 17:10:11 NVIDIA(0): Samsung SyncMaster (DFP-0): Internal Single Link TMDS
(II) Jul 28 17:10:11 NVIDIA(0): Assigned Display Device: CRT-0
(==) Jul 28 17:10:11 NVIDIA(0): 
(==) Jul 28 17:10:11 NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) Jul 28 17:10:11 NVIDIA(0):     will be used as the requested mode.
(==) Jul 28 17:10:11 NVIDIA(0): 
(II) Jul 28 17:10:11 NVIDIA(0): Validated modes:
(II) Jul 28 17:10:11 NVIDIA(0):     "nvidia-auto-select"
(II) Jul 28 17:10:11 NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) Jul 28 17:10:11 NVIDIA(0): DPI set to (85, 86); computed from "UseEdidDpi" X config
(--) Jul 28 17:10:11 NVIDIA(0):     option
(==) Jul 28 17:10:11 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp

Here is the complete /etc/X11/xorg.conf file as generated by nvidia-xconfig:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 256.35  (buildmeister@builder101)  Wed Jun 16 19:25:59 PDT 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Hor
share|improve this question

problem solved. the solution was easy and simple:

I just pressed the "auto" button of my monitor. sounds weird, but thats the way it is :/

I assume that some configuration using gtf (gtf 1280 1024 60)

also provided the neccessary results..

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .