Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

hi there so i have this laptop Compaq Presario C700 intel T2310 + 2.5GB RAM + 120GB HDD + intel GMA 965 im running Windows 7 ultimate + VS2008 VS2008 is fast but VS2010 is sluggish and laggy idk why i searched a bit and i found that i could get better performance on XP than Win7 is that true ?

share|improve this question
add comment

migrated from stackoverflow.com Jul 29 '10 at 3:26

This question came from our site for professional and enthusiast programmers.

closed as not a real question by Diago Sep 9 '10 at 12:54

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

Maybe it is a bit faster on XP due to a lower base memory requirement. But instead of grading down you should consider grading up: your RAM.

share|improve this answer
    
isn't 2.5GB enough ? BTW when i check ram usage i find only 40% –  Yassine Jul 25 '10 at 17:15
1  
In general, I would recommend you upgrading your RAM. Open a browser while developing, having the email client running and so on consume your RAM. –  Andreas Jul 25 '10 at 17:27
    
i think i have enough RAM for now; the problem is not related to RAM usage –  Yassine Jul 25 '10 at 21:43
add comment

It could be related to the graphics settings that VS2010 uses by default (the move to WPF also meant leveraging more intense graphics). You can turn the graphics settings down in Tools -> Options -> Environment -> General, under the Visual Experience section.

share|improve this answer
add comment

I use it in a Win7-64bit machine and it is about 10 times slower than VS2005, even turning visual experience down...

Probably the only way to speed it up is to disable intellisense or parts of it. Try looking at the options...

share|improve this answer
add comment