Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows XP system that has been running fine for a long time. However, yesterday I rebooted it for the first time in a while, and when it came back up, it did not let me log in to the system and came up with a box saying:

Windows Product Activation
This copy of Windows must be activated with Microsoft before you can log on. 
Do you want to activate Windows now?

Because the system does not have any internet access, I tried to run through the activation system by phone, but the key was rejected. I then rebooted the system again. It came up normally straight away - no activation screen, no trouble.

I have seen this on other computers before, but I have never found out why it happens. Does anyone know what could be causing this?

share|improve this question
    
I had W7 do this once, reboot fixed it also, who knows, some file did not load during the boot process or data got scrambled. –  Moab Jul 29 '10 at 14:15

3 Answers 3

Windows Activation uses the internal identifiers of a few hardware components to guess when the operating system is being started on another computer. It happens, especially on systems that are starting to age a little, that one or more hardware components responds just a little late or in an incorrect fashion, so that is it missing from the mix of info that is used for this check. As noted above a reboot may fix this. If it keeps re-occuring, consider checking if all components are still firmly attached within the enclosure and there's no dust-build-up on or around the circuit-boards and ventilation fans.

share|improve this answer

You can try to login windows in safe mode, Right click on my computer click properties. Under general tab you will find an option for change product key. Click on it and contact Microsoft they will provide you product key else you need to reinstall windows.

share|improve this answer
    
Thanks for the answer. The product key evidently works because it has been activated before, and after rebooting again, it works later too! The question here is more about what is (or could be) causing the activation to disappear very occassionally on a reboot. –  Mark Hatton Jul 30 '10 at 8:04

Even though it doesn't have internet access (would've probably failed anyways since it failed over the phone) have you tried running a malware scanner on it?

Other possibilities are the activation dlls could have become corrupt. Running scf /scannow could fix those. If not malware then I would think your WPA.DBL file could be corrupt, I believe this is where activation state would be stored in XP.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.