Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used sudo apt-get install blender to install blender on Ubuntu 9.10

But it doesn't open. When I click
Applications > Graphics > Blender (fullscreen)
or
Applications > Graphics > Blender (windowed)
nothing happens.

root@penelope:~# sudo apt-get install blender
Reading package lists... Done
Building dependency tree       
Reading state information... Done
blender is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 232 not upgraded.


root@penelope:~# blender
Compiled with Python version 2.6.4rc2.
Checking for installed Python... got it!
Xlib:  extension "GLX" missing on display ":0.0".
intern/ghost/intern/GHOST_WindowX11.cpp:177: X11 glxChooseVisual() failed for OpenGL, verify working openGL system!
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Resource id in failed request:  0xb7742ec0
  Serial number of failed request:  21
  Current serial number in output stream:  22
share|improve this question
    
unrelated to your problem but: you are logged in into your system as root AND use sudo? –  akira Jul 29 '10 at 13:38
    
LOL..sorta overkill but I didn't think it made a difference, I was just copy-pasting the commands from a forum. –  Dian Jul 30 '10 at 1:10
add comment

1 Answer 1

up vote 1 down vote accepted

Your Ubuntu seems to miss accelerated 3D graphics. You need to install a decent video driver; see System -> Administration -> Hardware Drivers if it suggests something for you already.

share|improve this answer
    
It says, No proprietary divers are in use on this system. –  Dian Jul 30 '10 at 14:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.