Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've upgraded three PCs from Vista to Windows 7 without incident, but the fourth one is a bit of a problem.

The Windows 7 install fails and rolls back to Vista with:

The upgrade was not successful. Your previous version of Windows is being restored

The Windows 7 upgrade advisor, both on-disc and the downloadable one from the Microsoft website, shows no potential problems for this PC prior to the upgrade, just standard warnings about iTunes reactivation and so forth.

This is my second attempt at upgrading this PC to Win7; after the first failure and rollback, I uninstalled a ton of unused software from the PC via add/remove programs, but the second attempt ended up the same as the first.

I really don't want to have to do a clean install on this PC, so are there any post-install logs or anything I can investigate to see why exactly why Win7 is failing to upgrade this PC from Vista, and to fix it?

Based on one of the suggestions, I checked this path

c:\$WINDOWS.~BT\sources\setuperr.log

Which contained this line

SetupGetInfDriverStoreLocationW failed for 'C:\Windows\inf\oem28.inf'[gle=0x00000490]

I checked that oem28.inf file and it relates to a printer on that computer -- so I went ahead and removed the printer and deleted the printer driver:

  • right-click within the Printers folder
  • select "Server Printer"
  • select Drivers tab, click driver, click Remove
  • confirm

as documented here. Now I'll try the upgrade again..

No dice. Still rolls back (but the printer error is gone from the log!). Some relevant lines from the setuperr.log file:

Failed to find driver file path. Error=00000002x {repeated ~ 6 times}
Failed to find driver file path. Error=ffffffffx {repeated ~ 6 times}
Plugin {e0cbf06c-cd8b-4647-bb8a-263b43f0f974}: BthMig: Failed to migrate bthport keys, bailing out
Failure while calling IDiscovery->Gather for Plugin={ServerPath="%windir%\system32\drmmgrtn.dll", CLSID={743B7FD2-8427-4b7d-B330-A95618DE2BFC}, ThreadingModel=Apartment}. Error: 0x80070057
Failed to check the certificate of the catalog file C:\Windows\System32\catroot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\1.CAT.[gle=0x800b010a]
Failure while calling IPostApply->PostApply for Plugin={ServerPath="%windir%\system32\drmmgrtn.dll", CLSID={743B7FD2-8427-4b7d-B330-A95618DE2BFC}, ThreadingModel=Apartment}. Error: 0x80070057

I finally tried uninstalling all drivers from this PC (all it had were the Nvidia drivers really), and attempted to do a third upgrade. Same problem. I watched it this time, so I know exactly what happened -- it got very, very far into the upgrade, after the video drivers are installed and so forth, then bluescreened at boot with DRIVER_IRQL_NOT_LESS_OR_EQUAL at the final stage and rolled back to Vista again. I assume that was the same thing that was happening before.

Oh well, I guess I have no choice but to do a clean install. :(

share|improve this question
    
I want to see how this pans out. :) Apparently some other problems have been with USB devices connected. Would be interesting if the driver was what was causing issues –  Ciaran Aug 2 '09 at 0:43
    
I'd like to know if you ever succeed as well - I had the same problem, tried many of the same things myself as well. And I really want to upgrade to Windows 7, too! :-( –  Keithius Aug 2 '09 at 13:10
    
I eventually gave up. The clean install worked fine, though.. I wish the logs had more detail on what was failing and why. –  Jeff Atwood Aug 2 '09 at 19:08
    
Bummer... but I hear ya on the logs thing - for all their verbosity, they don't actually tell you very much now do they? –  Keithius Aug 3 '09 at 12:29
    
Instead of "c:\$WINDOWS.~BT\sources\setuperr.log" did you mean "c:\$WINDOWS.~BT\sources\Rollback\setuperr.log"? I don't see a log in just sources\. (Troubleshooting my own failed upgrade...) –  Andrew Coleson Aug 29 '09 at 4:52
add comment

5 Answers

up vote 4 down vote accepted

Might be some useful logs files you can see.

Then I found the file C:\$Windows.~BT\Sources\Rollback\setupact.err had some useful info.

Details here.

share|improve this answer
    
giving the accept because this is the answer that got me headed in the right filesystem direction to find the log! –  Jeff Atwood Aug 2 '09 at 1:51
add comment

Many times, the errors present in setuperr.log/setupact.log may be a red herring. Even upgrades that complete successfully include such errors. What frequently happens in these upgrades that automatically roll back to the original OS is that some "out-of-box" device driver is blue-screening the system when it boots into the new OS for the first time. In such cases, there may be a dump file left behind after the upgrade rolls back; see #36402 for more details.

share|improve this answer
add comment
  1. Open up Run box and open MSCONFIG.

  2. Click on Services Tab and Hide Microsoft Services.

  3. Disable all the services on the list. Same thing with all startup items.

  4. Open CMD with elevated privileges.

  5. Type net user Administrator password and press Enter. It will say command completed successfully.

  6. Type net user Administrator /active:yes and press Enter. Again it will say command completed successfully.

  7. Restart the computer and then log in under the Administrator account with the password as password.

  8. Start the Windows 7 Upgrade again, this time it will finish.

I have tried it on four computers with the same problem that would not install Windows 7 Upgrade from Vista SP2.

share|improve this answer
add comment

The log files you're looking for may be the same as the Windows Vista setup log file locations.

C:\$WINDOWS.~BT\Sources\Panther\setuperr.log
C:\$WINDOWS.~BT\Sources\Panther\setupact.log

Edit: With the errors coming up in the update you gave, I'd consider uninstalling all the 3rd party drivers you've installed. Don't delete the driver files themselves.

If the problem persists, I'd personally go ahead with the clean install.

share|improve this answer
add comment

Perhaps you could unregister %windir%\system32\drmmgrtn.dll and then try again? It seems to have to do with drm migration - not really printer related.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.