Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I routinely work in Windows, Linux, and Mac, so I obtained this KVM switch:

http://catalog.belkin.com/IWCatProductPage.process?Product_Id=404586

Now, whenever I switch between Linux (Ubuntu 9.04) and Windows (XP SP3), I have to auto adjust my monitor, as everything appears fuzzy.

How do fix this problem?

share|improve this question

migrated from serverfault.com Jul 29 '10 at 12:59

This question came from our site for professional system and network administrators.

    
I've seen this even switching a KVM between systems running basically the same OS –  freiheit Jul 13 '09 at 2:44

4 Answers 4

up vote 5 down vote accepted

The most likely reason is that your different machines are running at different resolutions or refresh rates. Even if they're identical, though, different video cards produce subtly different output (*), so your monitor needs to adjust for optimal performance.

(*) Matrox used to make a big deal about how their black-to-white pixel voltage spike was sharper and faster than other manufacturers. You could see the difference on screen, so it wasn't all hype.

share|improve this answer

I have faced the problem on the same system with dual booting. When I shifted from Linux to Windows or vice versa I had to auto adjust so that screen borders were recognized correctly. Resolution was the same, 1024x768 on both OSes.

In Linux, install system-config-display if not already there so that you get file /etc/X11/xorg.conf or you can also use command (as root)

Xorg -configure :1 

to create a new configuration file in /root. See what the values are for HorizSync, VertRefresh, etc. in this newly created file. If there is nothing then you can specify things manually so that they are same as that on Windows. Use

man xorg.conf

to see what all you can configure in 'Monitor' section in xorg.conf.

You would have to find what the values are for these parameters in Windows. Look for some tool or maybe a graphics card driver that can tell you this information.

share|improve this answer
    
VERY odd. Thanks for pointing me to man xorg.conf. As it turns out, the default range for refresh rate is 62-73 if unspecified. I'm running at 75 Hz, so adding VerticalRefresh 75 to the monitor section set me up. Good post. –  Stefan Kendall Jul 13 '09 at 14:06
    
Are using a CRT? If not, refresh should 60Hz, and that is probably your problem. –  fstx May 10 '12 at 14:02

You might could try a DVI KVM instead. I use this one in the setup you described, and I have no problems: http://www.newegg.com/Product/Product.aspx?Item=N82E16817399024

share|improve this answer

Or you could use two different resolutions (perhaps it will count if you just change refresh rate for one) and the monitor should remember these two settings separately. As it is, using the same resolution, the monitor cannot really differentiate the two graphic streams even though they align differently...

...or as someone said, go digital ^^

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.