Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On PC-BSD 8.1 (KDE) I have four workspaces. I want to launch rdesktop 1.6 in one of them, full screen if possible (I'll settle for nearly-full in a window if I have to), and be able to do the following:

  1. Switch between windows in the remote session using Alt+Tab.
  2. Switch between local workspaces using either the default Ctrl+F1 or what I've switched it to, my preferred Alt+F1.

It seems if I use the -K option, I get 2 but not 1. If I don't, I get 1 but not 2. Is there no way to do this? How can I tell rdesktop to send or not send a specific key combination?

share|improve this question
up vote 0 down vote accepted

Use KRDC. You can switch on the fly at runtime between interpreting e.g. AltTab for the local or remote desktop. The switch can be triggered via a menu item, a toolbar icon or a (perhaps global) key shortcut.

share|improve this answer
Right, so you still have that extra step, same with rdesktop. Is there a to tell KRDC to gobble only Alt+Tab? – Kev Aug 3 '10 at 12:07
Meh, I just disabled global Alt+Tab, it works for what I need at this point, even though it's not quite what I was looking for. Thanks for your help. – Kev Aug 3 '10 at 12:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.