Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to configure my vista machine to run the Remote Desktop Server yet i'm having problems. I have configured it using the following instructions. Yet it doesn't work. I have disabled the firewall and antivirus software but to no avail. I know the client is set up properly as i can log in to my friend's Remote Desktop server. The client i am using is rdesktop. What else can I try?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Try to use protocol level 4, not the default protocol level 5.

Thus, the command should be:

rdesktop -4 [other params]

share|improve this answer
    
The client works its the server that is the issue, I know this as I can log in to my friends machine(he is running XP). I will however try it tomorrow when I get in. –  Dean Aug 1 '10 at 19:03
    
@Dean: XP does not require this parameter, only Vista does. –  harrymc Aug 1 '10 at 20:36
    
@harrymc Still no success with adding it as a parameter. –  Dean Aug 3 '10 at 9:54
    
@Dean: I understand you are having problems using rdesktop on Redhat to connect to Vista. I understand you can rdesktop to an XP machine. Correct me if I'm wrong. Which version of rdesktop? Vista 32-bits? –  harrymc Aug 3 '10 at 10:30
    
@Dean: rdesktop needs to be at least version 1.5.0 to connect to Vista. –  harrymc Aug 3 '10 at 10:37

If your server is behind a router (i.e., if you are trying to make this connection over the internet, not locally), you will need to forward port 3389 TCP to the server.

If you are unsure how to do that with your model of router, check out http://portforward.com/

For example, this is how you configure a Linksys WRT54G (a quite common and popular router) to forward that port.

share|improve this answer
    
Nope is not an issue as its internally before it reaches the router. –  Dean Jul 31 '10 at 20:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.