Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just noticed that I can no longer start, stop, or restart the Task Scheduler service. When I open a Command window and attempt to stop the service in that fashion, I get an "permission denied" error, even when running as Administrator.

Is there a solution to this issue? I am running Vista SP1.

enter image description here

share|improve this question
Please note that Microsoft has done this to prevent yo from stopping that service as it is crucial. – Tom Wijsman Nov 1 '11 at 13:44

5 Answers 5

up vote 3 down vote accepted

You should not disable Task Scheduler in Vista or Windows 7. Unlike XP, Vista actually uses Task Scheduler to perform system tasks.

share|improve this answer
I had to down vote this because it doesn't fix the problem. – dlux Feb 11 '11 at 20:22
And what happens when the service malfunctions, and you have other user-critical tasks to complete prior to a Window restart? Microsoft cannot protect users from themselves with everything they could do to adversely alter the operation of Windows. – user66001 Aug 24 at 3:52

Just found a way to a stop and then start, or restart, services that are launched under accounts like the SYSTEM account, causing even an Administrator-context cmd.exe process not to be able to manage them.

  1. Download Sysinternal's Process Explorer.

  2. Extract all files in

  3. Right click on resulting procexp.exe and select enter image description hereRun as administrator; Click Continue button on resulting dialog.

enter image description here

  1. Find svchost.exe in Process list, that has child process' of taskeng.exe.

  2. Right click on the svchost.exe identified in step 4. and select Properties.

enter image description here

  1. Select a Service; For the Task Scheduler click on Service Schedule line.

  2. Click the Permissions button.

  3. Add at least Write, if not Full control permissions to a group your user account belongs to, or just your user account, and click OK button.

  4. With the permission-changed service line still highlighted in the list, happily Restart or Stop (and the Start again, noting the consequences of not doing so in other answers to this question) your permission-changed service.

share|improve this answer

You can't stop the task scheduler. From Technet ...

The Task Scheduler service cannot be stopped or disabled by administrators using the Services Microsoft Management Console (MMC) snap-in user interface, unless special permissions are added to the administrator token.

There are some registry tweaks that claim to get it to stop, but your best bet is to use a tool. Security Explorer has a trial version that should work for you. If you want to prevent users from scheduling tasks, there is a way.

The best registry entry I found was below. But I don't have a Vista machine to test it on.

share|improve this answer
I already have that Registry flag set with that value. Maybe I've never been able to disable it and never noticed before. – RHPT Aug 2 '09 at 17:24

That is almost correct. Set it to 4 and reboot to disable. Some things will not work right such as updates (sometimes). Just re-enable when you go to run updates.

share|improve this answer
Please note that this is a crucial service and should most likely not be disabled. – Tom Wijsman Nov 1 '11 at 13:45

This is the behavior I'm seeing too.

There is a check box under the 'Services' tab of msconfig for 'Task Scheduler' though. Maybe that would be worth exploring?

share|improve this answer
if you uncheck this box - it just immediately rechecks itself – Simon Jan 12 '11 at 23:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.