Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

From some days ago I have a big problem on my laptop( run windows xp sp3) When I connect to internet I can ping web sites but when try to browse them some times it work correctly and some times the connection to server intrupted and I have to refresh the page several times. in this case browser show a connection problem immediatly after I click on address bar or a link on page( wihtout any try to connect to server) I use FireFox and opera and both of them have this problem. try another ISP and still I have this problem. I didnt use any proxy server and check the proxy setting. In this case Outlook also can't connect to mail server. this problem anfter some time or after restart windows have been fixed for a while. I check for virus and can't find anything. Is there any idea how can I fix it?

UPDATE: Thanks for your responses. I test them , also I use Open DNS setting and that dosent help me. last night I see that my local web application ( such as Adsl modem config web site , and sites that I set up on windows xo IIS ) aslo can't open and Internal Communication error apears ( Opera Message) that didnt relate to DNS settings or Internet connection.

share|improve this question
    
What kind of internet connection do you have? Is there a router? Have you tried other computers on the same connection? Have you done a virus scan? –  JNK Jul 30 '10 at 1:52
    
Thanks, I checked by virus scanner and nothing find, I used ADSL and there is just one Laptop directly connected to Modem, also try dialup and my GPRS, all of them same result –  Ashian Jul 30 '10 at 5:24
add comment

4 Answers

up vote 1 down vote accepted

That kind of connection problem is hard to diagnose. I might be wrong but I bet on a DNS problem. It's easy and fast to setup so I'd give it a shot. A DNS is a big server somewhere on the planet, which convert names (like google.com) to IP Addresses. The default DNS might be overloaded and doesn't respond everytime. Personnaly, I use the DNS provided by Google which are fast and always availables.

  • As JNK suggests in comments, remember your old settings for everything you change
  • go to Config panel > Network
  • right click on your connection > Properties
  • click on Internet Protocol (TCP/IP) > Properties
  • Select Use this DNS
  • primary : 8.8.8.8, secondary 8.8.4.4

Apply and you're done (no need to restart).

Note : my system is in french, so the instructions are not exactly the same.

share|improve this answer
1  
Please, before you make this change WRITE DOWN YOUR OLD SETTINGS as well! –  JNK Jul 30 '10 at 10:21
    
Man, this advice was simply fantastic, many, many thanks! The DNS by Google is blazing FAST! –  mabho Jun 28 '13 at 21:22
add comment

When the connection to a site is failing, run this command:

tracert the.site.domain

Edit your question to include the results. This will help us determine whether the problem is in your own PC, in the router, or in your ISP's network.

share|improve this answer
add comment

Since you have the problem on more than one connection, we can assume it's the laptop itself and not your DSL modem, so I won't recommend a firmware upgrade for your modem.

I think your problem is due to security software that's blocking your traffic. Such symptoms as you describe are often seen on machines with one or more of the following conditions:

  1. An expired trial copy of Norton or McAffee
  2. More than one firewall installed
  3. Messed-up proxy settings
  4. Some kind of nasty virus usin' up ALL ur bandwidth.

To troubleshoot, locate and uninstall any trial A/V software you're not using, then update the A/V app you are using.

If you still can't surf after that, disable the firewall on the machine and try again.

If you can ping names, your symptoms are probably not DNS-related (unless you've done something really odd to your DNS settings). I strongly recommend using your ISP's recommended settings; they're recommended for a reason.

share|improve this answer
add comment

Now this is a guess, but based on my experience with sudden problems. Do A Complete Virus Scan! Use any or a few of the most popular ones (free, whatever). Use the deepest scan possible.

I had some new, random problems and once I scanned completely, and MSE removed the problems it found, suddenly, everything seems to be working!!

Regards,

share|improve this answer
    
I check by F-Prot antivirus that I have one year membership and will upgrate every day. –  Ashian Jul 30 '10 at 5:25
    
I advise doing a scan and not relying totally on the AV filter. Regards –  Xavierjazz Jul 31 '10 at 17:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.