Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Somehow in the last 24 hours my account has changed to a 'Guest account'. I am using Windows 7 Professional.

The only application that I installed was GoToMeeting. I didn't notice anything unusual - it worked fine yesterday. I installed StarCraft 2 the day before that.

I have only one user account - so I can't seem to log on to any other account. I didn't notice anything unusual until I tried to edit my keyboard settings (my bluetooth keyboard's function key was not working) - UAC asked me to supply an Administrator password - but there was no way to click yes - or enter a password.

I am trying to stay calm. I tried scanning for viruses -but it also required UAC elevation so I couldn't. I can't think of anything unusual - the computer is a fairly new (2 months) MacBook Pro, running in boot camp.

Can anyone suggest anything to try?

---- EDIT ----- additional info: I entered the boot menu and went into the recovery options. It asked me for a user login - of course mine didn't work, but it did list 'Administrator' as a choice. It accepted a blank password, and would allow me to do some recovery options. If I try to logon as Administrator with a blank password normally - it says that this account has been disabled. I don't remember ever using it. A few days ago I setup my system to stop asking me for a password when waking from sleep. I followed advice on this site: http://www.howtogeek.com/howto/windows-vista/make-windows-vista-log-on-automatically/ (using the netplwiz command). I assumed everything was fine - and I did install Starcraft and GoToMeeting since then, so I know I have had normal access in the last 24 hours. I am thinking of trying to restore to a Restore Point - but don't have any experience with that.

share|improve this question
up vote 2 down vote accepted

Safe mode solved this problem. Apparently Windows 7 has a disabled Administrator account that is 'activated' in safe mode if there are no other Administrator accounts.

I had almost given up - I was starting some backups and prepping to reinstall Windows. Was really happy to find this fix before that. I ended up setting up my account and another account as Administrators.

I am looking through the Event logs, running virus scans and trying to identify what caused the User level to change. Anyway - back to normal ... Wish I had tried Safe mode earlier..

share|improve this answer
1  
If Safe Mode didn't work, you could use the Hiren's Boot CD to manipulate the user accounts. Just so you know when you get in a more annoying situation... ;-) – Tom Wijsman Jul 30 '10 at 9:24
    
thanks - good to know! – aSkywalker Jul 31 '10 at 2:21

Did the workgroup, or domain get changed for some reason? Did you add it to a new network? That'll do exactly what you are describing.

Otherwise it sounds like the SIDs or something got messed up somehow.

Anything besides those two installs (sc2 and gotomeeting)?

share|improve this answer
    
no network changes. It is a home office setup - very basic. System was up to date with patches and updates. Your questions made me think of some recent changes that I have done - I added it to my question above. – aSkywalker Jul 30 '10 at 4:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .