Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I go about debugging this - its really becoming a frustration.

This is the situation:

  1. Right Click an empty folder: pick the 'New>' Menu item.
  2. The first time I do this - everything seems to work fine and I can create (say) a new folder.
  3. The 2nd time (usually, sometimes 3rd,nnth) time the menu will display ok, but just selecting "New>" (that is highlight the menu item) results in no sub-menu, an hour glass and a (two) '' "Not Responding" in the Task manager.

Why two copies of the folder in Task Manager - I don't know if this is a clue - I have only one copy of the folder open on the minimized window strip thingy at the bottom.

If I kill the folders in Task Manager, I reset the problem - it will occur again on the next go (ie, the first 'New>' will work).

The issue does NOT seem related to the number of existing items in the folder.

I'm sure this is related to some third-party tool or something that has added a Context Menu - but how do I debug this and find the culprit ? --- UPDATE.

Looks like my explorer process spins off into an infinite loop: after the first post on here (thanks by the way), I ran 'regmon' and performed the test again.

This is what I see - over and over again - this is triggered by the first 'New>' selection, I guess the 2nd time the registry is locked out so the menu cannot be built the next time...Killing explorer kills this activity.

I have tried deleting the key "ShellNew" (wasn't able to), and then the individual keys within "ShellNew" (was able to): but seems to make no difference.

Regmon (not pasted here , but I can if would help) first shows the valid 'New>' items whizzing past, then it gets locks into this loop...

177.60397339    explorer.exe:1864   OpenKey HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew  SUCCESS Access: 0x10000     
177.60404968    explorer.exe:1864   DeleteKey   HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew  c000017d    Key: 0xE6FF9F40 
177.60406494    explorer.exe:1864   CloseKey    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew  SUCCESS     
177.60408020    explorer.exe:1864   CreateKey   HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew  SUCCESS Access: 0x2     
177.60408020    explorer.exe:1864   CloseKey    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew  SUCCESS     
177.60409546    explorer.exe:1864   OpenKey HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew  SUCCESS Access: 0x2000000   
177.60411072    explorer.exe:1864   QueryKey    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew  SUCCESS Subkeys = 0 
177.60411072    explorer.exe:1864   EnumerateKey    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew  NO MORE ENTRIES     
177.60412598    explorer.exe:1864   CloseKey    HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\ShellNew  SUCCESS     

Additionally: I also get 3-4 popup warning when I boot my machine about registry keys having to had been repaired. I'll post up the exact text of this when I capture it next time... it's possible these boot-up messages started occuring at the same time as this weird 'New>' thing....

share|improve this question

migrated from Jul 30 '10 at 4:56

This question came from our site for system and network administrators.

Well, I'll start you off, at least: the New entries are controlled by ShellNew entries in the registry. Jumping between those with a registry editor will likely pinpoint the problematic addition simply by looking for the one you don't remember having there before.

share|improve this answer
Thanks - Have updated my initial problem: now run a 'regmon' during the test - looks like explorer is getting into infinite loop.... – monojohnny Jul 29 '10 at 22:24

Download and install TweakUI from Microsoft, then use it to disable all of the "new" menu items. If that fixes it, start re-enabling them until you find the culprit.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .