Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using Google Earth, when I pan the map the application flickers white randomly.
The full window turns white for a very short time and I can see "Not Responding" flicker in the title bar.

Why does Google Earth flicker and what can I do about it?

MS Windows 7 64-bit
Intel Core i7 720QM
4.0GB Dual-Channel DDR3-1333
CLEVO CO. W870CU
NVIDIA GeForce GTX 285M
320GB Seagate Momentus 7200.3

The drivers are up-to-date and the temperatures are fine.

share|improve this question

2 Answers 2

up vote 2 down vote accepted
+50

Try the steps listed in Google Earth's support article:
Resolving Crashing and Graphics Issues on Windows Machines

Although some of the steps you have already done, here is the complete list without details:

Step 1: Clearing Your Cache
Step 2: Turning Off Atmosphere
Step 3: Switching Between DirectX and OpenGL
Step 4: Determining which Graphics Card You Have
Step 5: Updating Your Graphics Card Drivers
Step 6: Updating DirectX Drivers
Step 7: Removing a Corrupt myplaces.kml File

share|improve this answer
    
I didn't find it when I first went through the steps, but turning off Atmosphere in the View menu helps a lot. :-) –  Tom Wijsman Aug 3 '10 at 10:46

Try going into Google Earth, and click Tools -> Options and in the 3D View, try switching between OpenGL / DirectX, or modifying some of the other settings such as Antialiasing.

If nothing else, this could very well be a bug in the graphics drivers you are using.

share|improve this answer
    
Tried changing colors, OpenGL/DirectX, Anti-Aliasing, Anisotropic, ... :-( –  Tom Wijsman Jul 30 '10 at 14:55
    
Resize the window too. If it's worse with a larger window then that would reinforce the idea that your display drivers are at fault. –  ChrisF Jul 30 '10 at 14:56
    
Is it only an issue in this app? Do you use other programs that use OpenGL or Direct3d like games? Have you tried running something else using the 3d mode in windowed view instead of fullscreen? –  JNK Jul 30 '10 at 15:07
    
Reinstalled another last version of the drivers too... It is only an issue with this application. Other applications and full-screen games don't show such issues... Running it in a smaller window does not show the issue, but I want to run it in maximized... –  Tom Wijsman Jul 30 '10 at 15:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.