Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my Win 7 taskbar set to autohide but its often pops up... and just stays visible, obscuring the bottom of all other programs (since they are behaving correctly (as if the Task Bar isn't there b/c it's supposed to autohide).

Any way to force it to HIDE again?

share|improve this question
add comment

4 Answers

It won't hide again if you move your mouse over it and then away? I think it should once you restore focus to something else.

Some programs steal focus, which may be causing the issue. One that I have encountered a lot is logitech mouse mapping software - once you launch it, it runs in the background but may randomly steal focus.

Next time it happens, click on one of your open windows and see if the taskbar goes away again.

Are you using any mouse or keymapping programs?

share|improve this answer
add comment

See this, attached file at bottom of first post, instructions on another page.

http://www.sevenforums.com/customization/44913-disabletaskbarontop-disable-taskbar-always-top.html

share|improve this answer
add comment

This happens to me when a programs want's to give me a notification and windows is set to not show the notification.

The program in question just can't deal with it and keeps trying and the silly taskbar won't go away.

The only solution I have found short of reloggin/rebooting is to open the task manager (Ctrl+Shift+Esc) then find and kill explorer.exe.

Then in the run menu of task manager type "explorer".

Your desktop comes back, all taskbar and notification area icons accounted for (unlike in previous version of windows) and more importantly, your taskbar will now autohide.

No running programs should be harmed.

share|improve this answer
add comment

Adding to what DougMelvin posted, here's a script that I found a while back...

@echo off
taskkill /f /im explorer.exe 
start explorer.exe

Upon saving the file, I created a shortcut to the desktop and added shortcut key.

Ex. ctrl+alt+k

This forced the task bar to auto hide when explorer restarted.

share|improve this answer
    
Just curious... is this an acceptable answer? –  mdeitrick Feb 15 at 23:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.