Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I created a fuse mountpoint. After mounting, the file permissions are all screwed up and it says I cannot ls or cd. Permission denied.

The file permissions look like this: d????????? ? ? ? ? ? temp

and when i list the mounted devices I get: /dev/fuse on /temp type fuse (rw,nosuid,nodev)

I used mono-fuse. I just created a new folder with permissions 777 and then did a mount. After unmounting I can do all operations, but when I mount, I get such error.

I used HelloFS.exe that comes along with mono fuse for testing. Can someone shed some light on this weird behavior and what mistake ive done. Thank you !!

-Sethu

share|improve this question
1  
Some more information would be helpful, what are the exact commands you entered? –  Josh Jul 30 '10 at 18:22
    
I have a C# program that will mount azure storage on the mount point. Once I run this code, the permissions gets screwed up like this. I cannot do an ls or cd to that mountpoint. –  sethu Jul 30 '10 at 18:24
    
Can you include the C# program in the question, or is it private? –  Josh Jul 30 '10 at 19:56
    
Hi, The issue got solved. I was using mono fuse. mono fuse has properties AllowAccessToRoot and AllowAccessToOthers. Both were set to false. Thus I enabled these 2 bool variables and set allow others flag in /etc/fuse.conf . Now It works !! Thanks Josh !! –  sethu Jul 30 '10 at 20:46

1 Answer 1

up vote 0 down vote accepted

My best guess is that you're trying to access another user's fusermount (or sudoing your own) and, because fuse is (usually) single-user, you're having issues.

Either:

  • Make sure that you own the fusermount
  • Use the allow_other or allow_root option (or alternative)
share|improve this answer
    
Hey Josh, Im a newbie, can you please tell me where to use these options? in /etc/fstab ?? Thanks ! –  sethu Jul 30 '10 at 18:55
    
@sethu: It could be something like fusermount -o allow_root mountpoint but it depends on what you're trying to do and how you're trying to do it. –  Josh Jul 30 '10 at 19:57
    
Hi, The issue got solved. I was using mono fuse. mono fuse has properties AllowAccessToRoot and AllowAccessToOthers. Both were set to false. Thus I enabled these 2 bool variables and set allow others flag in /etc/fuse.conf . Now It works !! Thanks Josh !! –  sethu Jul 30 '10 at 20:46
    
@sethu: Could you click the tick next to my name to mark it as the solution? That way people can see at a glance that the question is already solved, and I get some points :P –  Josh Jul 30 '10 at 21:14
    
@Josh, oh i never knew that, and what is that 0,-1 and other stuff?? –  sethu Jul 31 '10 at 0:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.