Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set my terminal to open using zsh instead of bash, and it works for a week or so, and then it switches back to bash. Any idea of why this might be happening?

I'd really prefer to keep the change at the terminal level, and not actually switch my system shell.

share|improve this question
    
It might be worth mentioning this is about Mac OS X outside of the tags as well. –  oKtosiTe Nov 30 '10 at 0:50
1  
@oKtosiTe done. –  Yar Dec 18 '10 at 21:10

5 Answers 5

Run the command chsh. I did this and my zsh sticks on Snow Leopard.

share|improve this answer
    
Likewise. I used chsh to switch to zsh under Leopard, and it's stuck ever since. –  Lawrence Velázquez Nov 30 '10 at 0:54

How did you change your shell?

This works for me:

  1. Go to System Preferences.
  2. Open the Accounts prefpane.
  3. Authenticate so you can make changes.
  4. Control- or right-click on the name of your account and select Advanced Options.
  5. Under Login shell, select or enter the path to your zsh. (Note: I think this shell will also have to be listed in /etc/shells.)

You can also change it in Terminal itself:

  1. Open up the Terminal preferences.
  2. On the Startup tab, under Shells open with, Select Command (complete path) and enter the path to the shell.
share|improve this answer
    
I think firs way is actually working as chsh –  tig Jul 30 '10 at 23:20
1  
Sorry the question wasn't clear. I do #2. After a week or so, it switches back. –  Yar Jul 31 '10 at 18:33

Are you using MobileMe? At least for me, I have all kinds of problems with preference syncing. I can change a setting on my laptop and a couple days later it gets set back to the old setting (probably because my desktop is always running while my laptop is not).

It just strikes me as odd since mobileme is the only thing I've seen cause preference reset issues like this...

share|improve this answer

Some terminal programs allow you to run a program on login. Try running bash?

share|improve this answer
    
You must mean zsh... :-) –  oKtosiTe Nov 30 '10 at 0:51

How did you change it to zsh?

I briefly ran osx (not for very long, but longer than a few weeks) and just used chsh to change it to zsh and then the job was done. Do you have automatic updates running?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.