Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed evince on my Arch Linux system as a PDF reader, and everything was fine for a while. And then I installed GIMP. Since then, PDF files have been opening in GIMP. I've tried reinstalling evince, I've tried editing ~/.local/share/applications/defaults.list , I've tried editing /usr/share/applications/mimeinfo.cache, but PDF files still open in GIMP by default.

share|improve this question
    
What desktop environment (Gnome, KDE, XFCE, ...) are you using? – Benjamin Bannier Jul 30 '10 at 20:58
    
What DE are you using (if any)? [OOPS!] – dag729 Jul 30 '10 at 20:58
    
How are you opening the PDF? Nautilus, command-line, browser, etc.? – Matthew Flaschen Jul 30 '10 at 20:58
2  
I am using GNOME. (stupid 10 char limit) – Macha Jul 30 '10 at 20:59
1  
+1 for the "completion" :D – dag729 Jul 30 '10 at 21:00
up vote 5 down vote accepted

A bit of further research found that the offending file was ~/.local/share/applications/mimeapps.lst

share|improve this answer
    
Nice one! Anyway...what desktop environment are you using? – dag729 Jul 30 '10 at 20:59
    
GNOME, but the link applies to KDE, so they seem to be the same in this regard. – Macha Jul 30 '10 at 21:03
    
thanks for answer and question. i encountered this very problem lately but was to lazy to look into that matter. done now :) – matthias krull Jul 30 '10 at 21:47

I found that Firefox uses the XDG standard, so using the XDG command line apps to set default applications solved the problem for me.

$ xdg-mime default evince.desktop application/pdf

This tells anything using XDG to use Evince to open application/pdf files.

There's more info where I found this, on the ArchLinux wiki.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .