Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My DVD drive no longer recognises DVDs correctly, and I'm not sure how to correct this.

On startup, Explorer displays the drive as DVD Drive (E:) overlaid with a "DVD" label (I have 2 hard disk partitions, C: and D:)
However when I insert a blank (writable) DVD-R, the icon is displayed as CD Drive (E:)

Right-clicking on the drive icon results in an slight pause, then Explorer displays the context menu, in which all the entries are indented to the right:

Context menu image

Double-clicking on the DVD icon (which I would expect to launch Windows Media Player) instead causes Explorer to display the drive contents, so I just see a heading "Files currently on this CD", and underneath this is the icon for the VIDEO_TS folder.
If anyone's interested, the drive is an HL-DT-ST DVD+-RW GSA-H31N.

This is not a hardware problem: I can play DVDs in the drive using mplayer:

mplayer dvd://1 -dvd-device e:

...can play the DVD just fine; but Windows can't.

Before anyone asks: No, I don't have a restore point from before this started happening, so I can't just revert the system.

Because of the context menu appearance, I think there's some driver or shell extension disrupting things.
I've had a look at the Filter Drivers, thinking I need to remove something, but I'm not sure what should be there, and what shouldn't.

Can anyone offer any ideas for diagnosing this problem?

Update 2010-08-26

I've removed upper and lower filters, as instructed in this Microsoft Support article, and the Roxio Drag-to-Disc reference has been removed from the context menu along with the left-indentation.


  1. Click Start, and then click Run.
  2. In the Open box, type regedit, and then click OK.

  3. In the navigation pane, locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E965-E325-11CE-BFC1-08002BE10318}

  4. In the right pane, click UpperFilters.

    Note You may also see an UpperFilters.bak registry entry. You do not have to remove that entry. Click UpperFilters only. If you do not see the UpperFilters registry entry, you still might have to remove the LowerFilters registry entry. To do this, go to step 7.

  5. On the Edit menu, click Delete.
  6. When you are prompted to confirm the deletion, click Yes.
  7. In the right pane, click LowerFilters.
  8. On the Edit menu, click Delete.
  9. When you are prompted to confirm the deletion, click Yes.
  10. Exit Registry Editor.
  11. Restart the computer.

However, note that the context menu does not have the usual Open/Explore/Search entries.

When I double-click on the icon, I get the "Copy CD to CD" behavior, and Explorer shows "Files currently on the CD".

share|improve this question
add comment

2 Answers

Your context menu looks like it's just broken from an overly-wide icon. I'm guessing the line that has the little disc and reads "drag to disc" is at fault. It looks about the right wrong width and appears to be an image, not necessarily text (I could very well be wrong, but the font looks different).

If you can play the DVD using a different program, it seems that it's not your DVD drive but Windows Explorer that is making the mistake. Connected with the context menu, I'd say try removing a few of your disc-related tools (just temporarily) and see if the issue clears up.

To fix the double-click opening the folder, you may need to re-associate the DVD folder type with Windows Media Player. I can't remember off the top of my head how, so you'd need to Google, but if you know the menu that pops up when you insert a disc or flash drive, you'll need to select open in WiMP and set that as the default option.

share|improve this answer
    
Yeah, I'm inclined to uninstall the Roxio software because I hardly use it; but that's been installed for a couple of years, with all its context menu customizations, without any problem until recently. So maybe it's a red herring. –  njd Aug 24 '10 at 6:42
add comment

Well, after uninstalling various Roxio junk, and still finding that the DVD drive appeared as a CD drive, here's what steps finally fixed things.

The basic problem was that other CD/DVD utilities had removed the redbook and imapi filters, so the drive wasn't recognised properly.

I also had various ElbyCDFL and other LowerFilters from gawd-only knows where.

Merging this registry file restored the imapi LowerFilter and the redbook UpperFilter, which restored the DVD-RW functionality.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}]
"Class"="CDROM"
@="DVD/CD-ROM drives"
"EnumPropPages32"="MmSys.Cpl,MediaPropPageProvider"
"Installer32"="storprop.dll,DvdClassInstaller"
"SilentInstall"="1"
"NoInstallClass"="1"
"TroubleShooter-0"="hcp://help/tshoot/tsdrive.htm"
"Icon"="-51"
"LowerFilters"=hex(7):69,00,6d,00,61,00,70,00,69,00,00,00,00,00
"UpperFilters"=hex(7):72,00,65,00,64,00,62,00,6f,00,6f,00,6b,00,00,00,00,00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0000]
"EnumPropPages32"="storprop.dll,DvdPropPageProvider"
"InfPath"="cdrom.inf"
"InfSection"="cdrom_install"
"ProviderName"="Microsoft"
"DriverDateData"=hex:00,80,62,c5,c0,01,c1,01
"DriverDate"="7-1-2001"
"DriverVersion"="5.1.2535.0"
"MatchingDeviceId"="gencdrom"
"DriverDesc"="CD-ROM Drive"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0000\DigitalAudio]
"RegistryVersion"=dword:00000001
"NumberOfBuffers"=dword:00000008
"SectorsPerRead"=dword:00000010
"SectorsPerReadMask"=dword:ffffffff
"CDDASupported"=dword:00000001
"CDDAAccurate"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0001]
"EnumPropPages32"="storprop.dll,DvdPropPageProvider"
"InfPath"="cdrom.inf"
"InfSection"="cdrom_install"
"ProviderName"="Microsoft"
"DriverDateData"=hex:00,80,62,c5,c0,01,c1,01
"DriverDate"="7-1-2001"
"DriverVersion"="5.1.2535.0"
"MatchingDeviceId"="gencdrom"
"DriverDesc"="CD-ROM Drive"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0001\DigitalAudio]
"RegistryVersion"=dword:00000001
"NumberOfBuffers"=dword:00000008
"SectorsPerRead"=dword:00000010
"SectorsPerReadMask"=dword:ffffffff
"CDDASupported"=dword:00000001
"CDDAAccurate"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0002]
"EnumPropPages32"="storprop.dll,DvdPropPageProvider"
"InfPath"="cdrom.inf"
"InfSection"="cdrom_install"
"ProviderName"="Microsoft"
"DriverDateData"=hex:00,80,62,c5,c0,01,c1,01
"DriverDate"="7-1-2001"
"DriverVersion"="5.1.2535.0"
"MatchingDeviceId"="gencdrom"
"DriverDesc"="CD-ROM Drive"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0002\DigitalAudio]
"RegistryVersion"=dword:00000001
"NumberOfBuffers"=dword:00000008
"SectorsPerRead"=dword:00000010
"SectorsPerReadMask"=dword:ffffffff
"CDDASupported"=dword:00000001
"CDDAAccurate"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}\0003]
"EnumPropPages32"="storprop.dll,DvdPropPageProvider"
"InfPath"="cdrom.inf"
"InfSection"="cdrom_install"
"ProviderName"="Microsoft"
"DriverDateData"=hex:00,80,62,c5,c0,01,c1,01
"DriverDate"="7-1-2001"
"DriverVersion"="5.1.2535.0"
"MatchingDeviceId"="gencdrom"
"DriverDesc"="CD-ROM Drive"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.