Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Mac OS X 10.6

In Terminal preferences, the default startup window can be set to different style. But the keyboard shortcut "cmd-T" & "cmd-N" can only open the basic style terminal. How can I reassign the shortcut?

share|improve this question
up vote 39 down vote accepted

Open Terminal->Preferences, select Settings tab, choose Pro style and click Default button. Also open Startup tab and ensure that for the On startup, open option New window with settings:==Pro

share|improve this answer
9  
That is so ridiculously non-intuitive... thanks. – titaniumdecoy Feb 26 '11 at 0:22
    
Seriously, I just spent about 20 minutes trying to figure this out... – Andy White Apr 2 '12 at 21:53
    
@titaniumdecoy: What would be more intuitive for selecting the default settings than selecting an item in the Settings list and clicking the Default button? By the way, Shell > Use Settings as Default makes the settings profile of the current terminal the default and updates the profile to match the current window settings (rows/columns, title, etc.). Is that intuitive enough? – Chris Page Apr 6 '12 at 4:22
    
@titaniumdecoy: Normally you don’t need to change Preferences > Startup unless you’ve previously customized it. By default, On startup, open chooses the default settings profile, and if you change the default, it uses the new default. – Chris Page Apr 6 '12 at 4:26
    
@Chris Page: Seems that startup style was not connected to default one in previous versions of OS X, now it is connected unless startup style is different when changing default style. – tig Apr 10 '12 at 9:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .