Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a friends laptop following some viruses infestations there is a problem in starting the Windows firewall. The error is:

Could not start the Windows Firewall/Internet Connection Sharing(ICS) service on Local Computer.

Error 2: The system cannot find the file specified

When attempting to turn on automatic updates in the security centre, the message is:

We're sorry. The Security Center could not change your Automatic Updates settings. To try changing these settings yourself, go to System in Control Panel. On the Automtic Updates tab, select Automatic (recommended), and then click OK.

All the options under "Automatic Updates" are greyed out.

I've tried the suggestions below and many others:

http://windowsxp.mvps.org/sharedaccess.htm

http://support.Microsoft.com/kb/892199

http://windowsxp.mvps.org/repairwmi.htm

I can't do a repair install because the installer doesn't detect existing versions. It's XP pro service pack 3.

share|improve this question

2 Answers 2

I would scan your computer first for malware -> MalwareBytes

If that comes up clean attempt to start both the services in safe mode to confirm the files arnt currupt.

Repair Windows Firewall here

share|improve this answer
    
Thanks for the suggestion, I already ran a full scan a couple of times. –  Chris Porter Jul 31 '10 at 20:25
    
Do they start ok in safe mode? –  jer.salamon Jul 31 '10 at 20:47
    
Same problem in safe mode –  Chris Porter Jul 31 '10 at 21:04
    
try my added link –  jer.salamon Jul 31 '10 at 21:13
    
Thanks for the link. However the suggestions in that thread are largely the same as those in the links I already tried. In addition all the Firewall Administrative templates are set to "Not Configured" –  Chris Porter Aug 1 '10 at 10:08

After cleaning up a virus I found that it set various services to disabled, Automatic Updates being one of them. If you right click on My Computer, click Manage, open the Services section on the right you'll get a list of services. Find the ones mentioned, double click on them and change the startup preference to Automatic, then start them.

If they were disable with just a setting, that should handle it. If they are disabled because of missing or corrupt files, you might try manually downloading and reinstalling Service Pack 3 and the Windows Update installer. They can both be found on Microsoft's download site.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.