Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In the middle of writing an application that heavily relies on cURL I came across an error. The error cURL returns is

<HTML><HEAD><TITLE>Error</TITLE></HEAD><BODY>
An error occurred while processing your request.<p>
Reference&#32;&#35;179&#46;671d1f45&#46;1280621802&#46;1a9c0add
</BODY></HTML>

The command I use is

curl -T /test.txt http://idisk.me.com/myAccount/Public/myFolder/

MyAccount and MyFolder I replace with the correct info. Could it be that my host (Apple) is now denying curl uploads for some reason?

Thanks for any help this is really puzzling

share|improve this question
add comment

1 Answer

Try using a different user-agent:

curl -A 'other user agent' -T /test.txt http://idisk.me.com/myAccount/Public/myFolder/
share|improve this answer
    
Sorry to ask but I haven't heard of other user agent. Could you explain a little more? Also I still get the error... –  nosedive25 Aug 1 '10 at 0:36
1  
See user agent. It's a string that identifies the HTTP client. Some servers block curl, which you can bypass by spoofing a different agent (e.g. IE's, Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0)), –  Matthew Flaschen Aug 1 '10 at 0:47
    
Okay thanks I'll try that again. So I would replace 'other user agent' with something like Mozilla/4.0 ? –  nosedive25 Aug 1 '10 at 1:11
    
Or the whole string I gave. You can also find lists of common user agents to try. –  Matthew Flaschen Aug 1 '10 at 1:16
    
Hmmm now I just get unauthorized. If I run it again I get the error I previously got. –  nosedive25 Aug 1 '10 at 1:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.