Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set up the parental controls on a standard user account in windows 7, so that the user could only run specific programs that were authorized. I then logged in to that account and tried to run several programs - nothing worked other than the ones I had disabled. Good so far.

However, then I tried to run regedit, and succeeded! Not only that, I could modify the registry!

Is this really an acceptable behaviour of a standard user account with all programs disabled? Why could I even run regedit.exe? I certainly didn't flag it as an exception to the "No programs allowed to run" rule. :(

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Yes, any user account can run regedit, but anything beyond HKEY_CURRENT_USER can't be modified. If you're using something as simple as Windows Parental controls to block stuff, I wouldn't think the blockee would know about, much less access, regedit. If not, you may want to play around with the security policy, or secpol.msc. This should help.

share|improve this answer
add comment

Normal users cannot launch regedit.exe. I suspect the account isn't really a "standard user" as you claimed or you clicked through an elevation prompt without noticing.

share|improve this answer
    
Windows says it's a "standard user", and yet I can run regedit and meddle with the registry on it. There are no elevation prompts to be found. :( –  Colen Aug 1 '10 at 7:17
    
Have your UAC settings been changed? (Start menu search for "uac" and hit Enter) –  Rafael Rivera Aug 1 '10 at 19:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.