Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to boot into GParted-Live or Ubuntu-Live off a USB, it just won't happen.

I formatted a USB with files for GParted-Live found here: http://gparted.sourceforge.net/liveusb.php and the Ubuntu ISO.

Start the box, F12, boot menu to USB, I get...

SYSLINUX 3.86 2010-04-01 CBIO Copyright (C) 1994-2010 H. Peter Anvin et al
No DEFAULT or UI configuration directive found!
boot: _

I attempted this with a bunch of different utilities... http://en.wikipedia.org/wiki/List_of_tools_to_create_Live_USB_systems

I'm a noob, help me. :(

share|improve this question
    
What OS are you using to create the USB stick? Windows? Linux? –  Hamish Downer Aug 1 '10 at 22:31
    
Make a FAT16 format! it worked for me –  user117062 Feb 6 '12 at 18:05

6 Answers 6

Just use unetbootin. Format the stick with fat32 and use the tool.

share|improve this answer
    
+1. I had a similar problem as the OP: My Acer BIOS hang while loading its boot menu for selecting the USB stick, probably because it would not recognize the hidden NTFS/HPFS in the GParted Live image. Your solution worked like a charm. –  PointedEars Nov 24 '13 at 5:14

When you get that message, it means SYSLINUX can't find the configuration file, syslinux.cfg (or it is indeed not written properly - unlikely in your case). For GPartedLive, it is located in /syslinux.

A quick workaround is to copy the contents of /syslinux (everything in it) to the root of your USB drive. SYSLINUX will always look in the root for syslinux.cfg. SYSLINUX 3.86 also seems to have some bugs with its ability to find the configuration file when it is nested inside directories - SYSLINUX 4.0 seems a lot more reliable and resilient.

For a not-so-quick-and-less-likely-to-work-but-potentially-cleaner workaround, try manually telling SYSLINUX where to look by doing the following (assuming you're using Windows) -

  1. Download SYSLINUX 3.86.
  2. Extract win32\syslinux.exe to your desktop.
  3. Run the Command Prompt as administrator (Start -> All Programs -> Accessories -> right-click on Command Prompt, click Run as administrator).
  4. Find your desktop, if Windows Vista/7, usually, cd \users\username\Desktop, replacing username with your Windows username.
  5. Type syslinux.exe -fma -d /syslinux H: replacing H: with the letter of your USB drive. Be careful - do not replace H: with C: or whatever your Windows drive is, or you won't be able to boot Windows anymore.

Try rebooting again, and see how it goes. It might not work due to the bug mentioned above.

You could also try replacing SYSLINUX 3.86 with SYSLINUX 4.02; it is a bit tedious and you'll have to do it all again when GParted updates itself unless they upgrade to SYSLINUX 4.x. Leave a comment here and I'll write up some further instructions for doing that if you're interested.

share|improve this answer
    
Thanks a lot for your thorough answer, but after trying both of your recommendations, it still is not working. Is it that hard to do it with SYSLINUX 4.02? I'm interested I suppose. Thanks again. –  user44463 Aug 31 '10 at 14:21

It looks like it's found something on the USB stick and then something is wrong. From a quick google some things that might help are:

  • make sure you delete everything off the USB stick before copying on the new files. Old files mixed in might confuse the boot process. (Bug report) (As for creating the USB stick, UNetBootin has always been reliable for me.)
  • try the solutions suggested here.
share|improve this answer
    
All or most of the utilities I've attempted do format the USB drive as FAT32 (if not I've done it myself), so the stick is clean. The only thing I can think of is replacing syslinux with the newer one, but I have a feeling it would produce the same error as it looks pretty serious. So... That doesn't solve my problem. –  user44463 Aug 2 '10 at 7:04

A good guide for the Unetboot suggested by Hamish is at: http://www.howtogeek.com/howto/13379/create-a-bootable-ubuntu-9.10-usb-flash-drive/

however i must say that MY personal favorite is the "Universal USB Installer". it has never let me down yet and it gets a more specific configuration for the major distributions.... IMHO Unetboot simply guesses what would be done while the universal installer has specific methods built-in. a guide for it is here: http://www.howtogeek.com/howto/14912/create-a-persistent-bootable-ubuntu-usb-flash-drive/

good luck.

share|improve this answer

In my tests and tries I had in the last 6 months, I found that some USB sticks did not work, until I actually deleted all partitions from the device. That was done using GParted or simply fdisk. I think this is related to some partition table that GRUB could not find, or something like that. I found that for a stick that never worked in the past, manually deleting all partitions on the device, rewriting the partition table fixed the problem. I then could install Ubuntu on the device, making sure that GRUB is indeed installed on the right device, and it worked just fine.

share|improve this answer

Have a look at my post:

Linux USB Key - Only able to boot when formatted to FAT (Gigabyte motherboard)

I managed to get it working by formatting the USB stick to FAT (Not FAT32) and this worked with my Gigiabyte motherboard.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.