Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows Vista Home Premium Service Pack 2. In my Control Panel (Control Panel -> Hardware and Sound -> AutoPlay) "Use AutoPlay for all media devices" is turned on. But still AutoPlay is not working. When I trying to open "Edit group policy" (Control Panel -> System and Maintenance -> Administrative Tools -> Edit Group Policy) an error message is showing like below:

MMC cannot open the file C:\Windows\system32\gpedit.msc

This may be because the file does not exist, is not an MMC console, or was created by a later version of MMC. This may also be because you do not have sufficient access writes to the file.

I searched for gpedit.msc file in the system32 folder. But there was no file with this name. I am using HP Pavilion DV2910TX Notebook. I tried reformatting my Operating System using System Recovery process. But after reinstalling OS still gpedit.msc is not available there.

This problem is only occurs after installing VMware Workstation 7.0.0 build-203739. How can I turned on AutoPlay?

N.B.: I don't want to uninstall VMware workstation.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The Group Policy editor does not come packaged with Windows Vista Home Premium. You can manually adjust this behavior by using the Registry Editor (regedit.exe). Relevant instructions can be found at Microsoft Support, reproduced below for your convenience.

For operating systems that do not include Gpedit.msc, follow these steps:

  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following entry in the registry: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer\NoDriveTypeAutorun
  3. Right-click NoDriveTypeAutoRun, and then click Modify.
  4. In the Value data box, type 0xFF to disable all types of drives. Or, to selectively disable specific drives, use a different value as described in the "How to selectively disable specific Autorun features" section.
  5. Click OK, and then exit Registry Editor.
  6. Restart the computer.
share|improve this answer
    
There was no sub-entry under HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\policies. Can I made that manually? –  chanchal1987 Aug 2 '10 at 6:53
    
Value 0xFF is to disables AutoRun on all kinds of drives. What is the value to enables AutoRun on all kinds of drives? –  chanchal1987 Aug 2 '10 at 6:57
    
Set it to 0. But the fact it's missing could mean adjust this policy isn't the answer to your problem :( –  Rafael Rivera Aug 3 '10 at 3:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.