Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've bought a powerful machine, Intel I7 720Q with 8 GB RAM and 7200 RPM HDD and Radeon 5870 with 1GB VRAM, and after installing the new Adobe Master collection CS5 I found out, that both Photoshop versions x86 and x64 are very slow (I have a legal copy!)

E.g. when I open a 3MB file and I'm trying to move it with the hand, or scroll, it is going very slowly, laggy, 10x slower than on my 4 years old machine with CS2 !

Do I have to enable any kind of acceleration or something?

Thanks

share|improve this question
    
Did you finally find the answer to your question? –  r0ca Aug 12 '10 at 0:07
    
Why would anybody buy the Master Collection? –  paradroid Nov 3 '10 at 13:51
1  
@jason404: The master collection is heavily reduced in price for students at our university. 75% discount or something so I can see why people here might buy it. –  Chris Nov 12 '10 at 18:33
    
Strange, I'm running a much older machine and Photoshop CS5 x64 runs perfectly fine. I'd make sure your Graphics Card's drivers are up to date. –  Django Reinhardt May 6 '11 at 20:17
add comment

5 Answers

up vote 10 down vote accepted

Wow, seems CS5 is slow for a lot of people!!

I've found this KB from Adobe regarding OpenGL and GPU acceleration:

GPU and OpenGL support | Photoshop CS4, CS5

I'm pretty sure it could help you because you do have a powerful computer and this shouldn't cause CS5 to act like this.

Then, read this, for some other tweaks:

Optimize Photoshop performance | CS4, CS5 | Windows 7, Vista, XP

If you don't have a professional graphics card try this:

Preferences > Performance > GPU > OpenGL advanced settings > basic mode

share|improve this answer
add comment

I disable "enable openGL drawin" and restarted PS and... WOW - now everything works soo fast :)

share|improve this answer
    
is this 32 or 64bit version? –  w3d Aug 6 '10 at 14:22
    
Another happy camper. Unchecked Edit>Preferences>Performance>Enable openGL drawin>ok Now runs great. Thanks –  user57468 Nov 30 '10 at 20:29
add comment

I've just read that many people have problems like me. Especially with scrolling.. This is a patch for it.. Didn't try it yet though

http://www.adobe.com/support/downloads/detail.jsp?ftpID=4733

share|improve this answer
add comment

I think you have some problem or misconfiguration with the hardware aceleration. I use CS5 in a Acer Aspire netbook with 4Gb ram, Intel Core Duo t5800 (very average) and a Intel Mobile 4 VideoCard, and it works reasonably well.

In Preferences-> Performance, I´ll try first with the Memory Usage option and the scratch disk, it's better to use a disk where the Photoshop is not installed, if you have 2 or more.

And of course enabling the OpenGL aceleration.

share|improve this answer
add comment

I had the same problem, everything slow on a decent laptop. Instead of disabling "openGL drawin" I set it basic under advanced settings, and voila. (64bit)

share|improve this answer
add comment

protected by Community May 30 '11 at 14:25

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.