Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use "echo 0 > /proc/sys/vm/swappiness" to set swappiness but even if I'm root i've got access denied. Do you know what should I do to unlock it ?

share|improve this question
    
It may happen that even if SELinux status is disabled, one would get permission denied issues. –  suresh Dec 1 '11 at 20:16
add comment

2 Answers

up vote 4 down vote accepted

I suspect SELinux. Try getenforce and if it returns enforcing, you can temporarily disable SELinux with setenforce 0. For permanent disablement see /etc/selinux/config.

Before disabling SELinux you may try sysctl -w vm.swappiness=0.

share|improve this answer
add comment

You might want to check if SELinux is active. It imposes restrictions even on root.

The commmand sestatus will tell you if SELinux is active.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.