Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Here is the output from df -h:

Filesystem                  Size  Used Avail Use% Mounted on  
/dev/mapper/rootvg-rootvol  39G   31G  5.7G  85% /  
/dev/sda1                   99M   13M   82M  14% /boot  
tmpfs                       2.0G     0  2.0G   0% /dev/shm  
                           257G  608K  257G   1% /mnt 

And my /etc/fstab:

/dev/rootvg/rootvol     /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
LABEL=SWAP-sda2         swap                    swap    defaults        0 0

How can I mount and use the last drive (257G)?

share|improve this question

It is mounted, that's why it's appearing in your mount table (which df is showing you)!

The last field, 'Mounted on', tells you where in your file system it is. So you can access the files on the drive by looking at the contents of /mnt.

share|improve this answer
I tried accesing using cd /mnt and then tried creating a new file sudo mkdir newDir yet I am getting a permssion denied error? – Akihlesh sharma Aug 2 '10 at 15:29
thanks for the help – Akihlesh sharma Aug 3 '10 at 14:53
You probably don't have access to create files on the remote server as root, hence the error. Try it as a normal user instead. – David Given Aug 3 '10 at 16:02

As others have mentioned, the drive is already mounted. This is an NFS share, you can tell by the machine:/export/path syntax on the left (the device type).

If you want to know how to mount it now, it's already mounted.

If you want to know how to mount it by hand, as root, type:

mount -t nfs /some/local/mount/point

If you want it mounted every time you rebooted, you'd need to change your /etc/fstab and add this line: /some/local/mount/point nfs default 0 0

I'd think a bit about putting it in /etc/fstab - this means you would then have a boot dependency on that NFS server, and it may hang your box on boot if the NFS is unavailable. You could configure your box to mount it using the automounter, which would bring in the mount only when needed, but that's out of the scope of the original question.

share|improve this answer
Thanks I could at least unmount and remount again. It seems my sysadmin hasnt set proper permissions or something, coz I still cannot create a directory or touch a file. – Akihlesh sharma Aug 3 '10 at 14:54

It is already mounted per your df -h output. If you're getting a permission denied error when you cd /mnt, try:

chmod 777 /mnt

However, you may need to chmod from the nas server (

chmod 777 /bigco/data

777 is just for troubleshooting, so be sure to use the appropriate permissions for security's sake.

share|improve this answer
777 permissions are a bad idea. Even for troubleshooting.. – matthias krull Aug 2 '10 at 22:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .