Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My machine is a HP Pavilion Elite HPE-110f, and the hard drive is WD10EADS-65M2B1 SCSI Device. When my machine arrived, it had RAIDXpert running on it, and about 3 months after I bought it, it started reporting bad sectors. I also ran the WD DataLifeguard program, and it also reported errors - and said it couldn't fix them. As the machine was under warranty, I shipped it off to HP, who cleaned off the disk and shipped it back.

HP did not include any indication of what the problem was, or what they had done - except that they cleaned all the data off my disk.

On the second day after getting it back, RAIDXpert started reporting errors again (same sectors as before). I contacted WD, and they told me that the disk is "not a RAID device" - whatever that means!

I then ran WD DataLifeguard program again (twice), and each time it came up with a message to the effect that it was bringing down the computer "to prevent damage to the computer"... and brought the computer down! It didn't do that before I sent it off to HP!

I have posted the above info on the HP support site, and there have been many views but no answers! Could someone tell me what is going on, and what I should do about it? I don't need a terabyte of space, so is there some way of just marking the bad sectors (if the error messages are valid) as unavailable, and reformat? Or is it possible that a terabyte just strains the various scanners to the point where they die or give erroneous messages?

TIA

share|improve this question
2  
when you say they "cleaned off the disk" does that mean replace the disk? To me it sounds like they did nothing. –  user33788 Aug 2 '10 at 14:25
    
Thanks Tony - all files gone, except for Windows and some HP diagnostic stuff! –  Paul Morrison Aug 2 '10 at 15:23
add comment

migrated from serverfault.com Aug 3 '10 at 6:25

This question came from our site for professional system and network administrators.

2 Answers

It appears HP just reformatted the disk, hoping the problem gets away. It won't, your disk is broken. Ask for a replacement, and if they want you to send in the whole system again, write the serial number of your disk so you'll notice if they send the same again. Also, I would insist on getting just a replacement disk, without the annoyance of having to ship your whole computer.

share|improve this answer
    
Sven, is there some way to get the system to avoid the bad sectors - I don't mind doing a reformat myself, as I had already backed up all the important stuff... –  Paul Morrison Aug 2 '10 at 15:21
    
BTW the odd thing is that these two scanners are the only things reporting errors - is it possible that they can't handle a terabyte? –  Paul Morrison Aug 2 '10 at 15:24
    
No. You can't trust the disk anymore, it is broken. My policy: A single broken sector means a dead disk, as there is a good chance the sector next to the broken ones will die next. –  SvW Aug 2 '10 at 15:44
    
Latest news: WD says they also think the disk is broken, so it seems the HP tech somehow didn't change the harddrive, although s/he apparently ordered a new one... Go figure! I have shipped the whole thing off to them again, with recommendations to run WD Data Lifeguard before returning it to me! Will keep you posted. –  Paul Morrison Aug 5 '10 at 19:08
    
Got my machine back from HP, and they have now put a Seagate SCSI hard drive in it, so I definitely have a new disk! They have set up RAIDXpert to run, but the disk is not marked RAID Ready, so does anyone know if there is any point in running RAIDXpert?! FWIW RAIDXpert says no bad sectors! Hoping for the best! –  Paul Morrison Aug 12 '10 at 16:08
add comment

It's likely you didn't explain the problem to HP. The problem is that your HD has many bad sectors and needs to be replaced. The programs you used to find this out are not supported by HP as diagnostic tools however.

WD isn't helping their image either with the 'non-RAID drive' line (that drive is not meant for use in a RAID and may report errors; you however are not using it in a RAID capacity).

Call HP, take note of the case number and CSR's name, explain that you believe the HD has many bad sectors. They will ask you to run a long diagnostic (and explain how). Your computer will almost certainly fail the long diagnostic (it's call long because it should take hours to finish). Call HP back and tell them you have a case number already, give them the info you wrote down. They'll have you send the computer back in (if it failed the test, which it should). The paper you receive back with the computer should explain exactly what HP did (it may be cryptic, but the info is there).

share|improve this answer
    
Thanks Chris, but they did that... and it passed their test! However, the long test hung trying to test the Atheros ... They said they would call me back, and they never did! Sounds like I have to talk to someone senior :-) –  Paul Morrison Aug 2 '10 at 16:18
    
It's possible the disk is good and something else is bad. Bad Sector errors aren't terribly common these days as the drive usually relocated on the fly. –  Chris S Aug 2 '10 at 18:28
    
Re Chris' suggestion: is it possible the problem is with the AMD AHCI Compatible RAID Controller driver - the version no. is 3.2.1540.14. Is there any way to test this? –  Paul Morrison Aug 3 '10 at 0:06
    
And by the way, Chris, they didn't include any explanation last time - although they apparently reported to the case manager that they had changed the drive and motherboard... –  Paul Morrison Aug 5 '10 at 19:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.