Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Last night a Windows update on my Windows 7 machine added a new "Homegroup" icon to my desktop.

I don't want the icon on my desktop but can't see any way to get rid of it.

It's not listed in the desktop icons under personalisation settings and it's not a regular shortcut so can't be deleted in the usual manner. The context (right click) menu also provides no suitable option.

Any ideas?

share|improve this question

5 Answers 5

up vote 3 down vote accepted

You need to modify some registry keys. Here are the instructions on Microsoft's Windows 7 forums.

share|improve this answer
    
That worked great. Thanks –  Matt Lacey Aug 3 '10 at 9:29
  1. Go to "Folder Options"
  2. Click "View"
  3. Scroll down to "Use Sharing Wizard (Recommended)", it must be checked
  4. Uncheck the checkbox
  5. Click "Apply" (the icon will be removed from your desktop)
  6. Recheck the checkbox (the icon will not be back)
share|improve this answer
    
Perfect, this works on Windows 8 too. I have no idea why the Homegroup icon suddenly appeared. Maybe it was because I updated my network drivers. –  Wyatt O'Day Mar 25 '13 at 6:52

Or, if you don't fancy modifying your registry, just stop and disable the follwing services:

HomeGroup Listener
HomeGroup Provider

Ben

share|improve this answer
    
For those who don't use HomeGroup at all, this is a much cleaner solution. –  mindless.panda Aug 9 '11 at 0:57

Following the link provided by Alex, I found an easy way to get rid of Homegroup icon from desktop.

Quote from zzark's answer:

right-click on the Homegroup icon, select homegroup settings, then select leave homegroup.

share|improve this answer
    
I'm not sure that's what the poster meant, because he didn't say he wants to leave the homegroup - he might be using it, he just wants to remove it's icon from the desktop. –  agentmike Oct 17 '12 at 8:48

I had to revisit this as that icon reappeared on my desktop, and the answer in the form wasn't working. I was getting lots of import errors. so did a little more searching, and Found another answer as to how to get rid of the icon, that doesn't make you copy paste and import. nor does it have you leave the home group or disable related services

http://answers.microsoft.com/en-us/windows/forum/windows_7-desktop/unable-to-remove-homegroup-icon/699c4550-c88e-4e0c-b30c-339ca25e52f8

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.