Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've this problem when I want to use "Host only" network adapter in VM-Ware 7.0 this is the error message:

The host-only adapter driver does not seem to be running. If you have not rebooted the host since installing the host-only network adapter, you need to do so before you can use this support. Otherwise, check the system Event Log for an explanation of why service VMnetAdapter did not startup properly. Failed to connect virtual device Ethernet0.

I looked at my device manager in the host system "Windows 7" but I couldn't find the VMware network adapter at all.

And I tried to reinstall it by "Virtual Network Editor" but it doesn't work

So please how to reinstall these drivers and adapters ?

share|improve this question
Did you manage to figure out how to reinstall the VM nics? – Synetech Jul 13 '11 at 3:21
No i didn't till now – Wahid Bitar Jul 19 '11 at 11:40

7 Answers 7

Stop the VMware services first, then run the following command:

vnetlib.exe -- install devices

On a 64-bit system replcae vnetlib.exe with vnetlib64.exe.

share|improve this answer

It seems that few people have needed to reinstall the host virtual adapters (or at least if they did, they just resorted to reinstalling VMWare instead of just the adapters), so it’s no surprise that there are very few references to fixing it. Fortunately, it has come up and a solution does exist.

What you need to do is to use the vnetlib utility (it should be in the VMWare installation directory).

Someone on the VMWare forums has attempted to document the vnetlib command and another tried to use it to add the host virtual adapters.

Ulli Hankeln has done an even more through job of documenting vnetlib at his Sanbarrow site (which basically, is the online VMWare bible). He also lists a few other ways to manage the network settings.

Anyway, what you can do is to manually reinstall the adapters by using the add adapter argument to vmnetlib, and then managing all the settings, but it’s much easier to just reinstall the VMWare network services:

> vnetlib.exe -- install devices
share|improve this answer

I came across the same issue. After pocking around VMware i found a way.

On the workstation click:

  • Edit

  • Virtual Network Editor

  • Add Network and choose the network to add ( VMnet1,2,3 and so on)

  • Click 'OK' twice and you should be good to go...

share|improve this answer
this is the answer, adding the net the virtual interface is avaliable again. – Francisco Tapia Jun 3 at 19:44

I disabled my VMware network adaptor in Windows 7.

After enabling it in Windows 7, it also works again in VMware.

See if that works for you.

share|improve this answer
That does not apply because he does not have a VMWare network adapter in the host OS, so he can’t disable/enable it. He’s asking how to re-install it. – Synetech Jul 13 '11 at 3:21

I had the same issue, and I fixed it by re-running the installation and selecting Repair as the option. That fixed the network problem, found in this solution.

I also tried the other answers without success.

vnetlib.exe -- install devices

I'm using Windows 8 with VMware Player 6.0.1 build-1379776

share|improve this answer

Run vmnetcfg.exe and just press "Restore Default".. :)

Generally, clicking "restore default" restores basic connectivity. You can then configure additional options as needed. Essentially, this reruns the initial network configuration setup and reinstalls all adapters/resets all network settings.

share|improve this answer
Welcome to Superuser, please be aware single line answers are commonly frowned up on :( could you elaborate on your answer – 50-3 Oct 2 '13 at 12:28

Just my 2 cents about my experience regarding the loss of my VMware Virtual Ethernet Adapters for VMnet8, VMnet1 after I upgraded my windows 7 to 10. I could open my Vmware player 6.07 and my virtual machine (win xp) , but the internet connection inside my VM wasn't working. I read around on internet to find out the cause and found that the virtual adapters were missing. I also noticed that the adapters had become unknown devices in my device manager in control panel. I tried to find out how to restore those virtual adapters and came upon some suggestions to use vmnetcfg.exe along with vmnetcfglib to restor the default as in one of the posts above. I was able to find the files at this website Vmnetcfg download (Not trying to promote that site at all, just for convenience). I chose the VM player 6.06 although mine was 6.07. When I clicked on restore default, the virtual adapters VMnet8, VMnet1 were not restored, but in control panel/admin tools/services, I saw two new services installed . They were Vmware dhcp and VMware Nat.I made sure all VmWare services were started and I launched my VmWare player and opened my win xp VM. The internet was working fine. That's how I fixed my problem and hope it helps someone else.

share|improve this answer
You should format your answer in a more direct way such as 'Step 1, Step 2, Step 3' versus storytelling in a large text block -- which can be hard to navigate. – Insane Nov 25 at 0:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.