Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

my squid server is set to use the ncsa module to do authentication. and i can use this proxy with web browsers (IE/FF). i configured my transmission as:

"proxy": "my.proxy.ip",

"proxy-auth-enabled": true,

"proxy-auth-password": "mypassword",

"proxy-auth-username": "myname",

"proxy-enabled": true,

"proxy-port": 31288,

"proxy-type": 0,

after i started my transmission daemon, i still see TCP_DENIED/407 in my squid log. it seems that transmission did not provide the user account info. to the squid server, and the request is denied.

does anyone how to fix this?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

it is actually not an issue. my bad :)

the above setting is correct. the TCP_DENIED is not responded from squid, it is from the BT tracker. so i was denied by the tracker, not my squid service.

share|improve this answer

Bitorrent makes two kinds of connections, http connection to the tracker (usually on port 6969) and then the actual transfer (usually on port 6981 and up) A proxy setting can work on the first type and on transmission for mac the proxy settings that I have specifically says connect to tracker with a proxy. The other connection is not http and therefore will not authenticate.

If you were to use wireshark and watch the connection I would be willing to bet that the connections to the trackers are working, and the deny you are seeing in the log is for actually trying to download content.

There are a couple of possibilities that you can do at this point. I am guessing that the squid box is also your gateway. So the easiest solution should be to modify the iptables and port forward to your computer the necessary ports (see below). That way for transmissions sake it thinks it is on the web and should work fine.

iptables -t nat -A PREROUTING -p tcp --dport 6881:6889 -j DNAT --to-destination <transmission_ip>
iptables -A FORWARD -s <transmission_ip> -p tcp --dport 6881:6889-j ACCEPT

This solution does bypass squid.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.