Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I downloaded Notepad2 and placed it in

C:\Program Files\Notepad2

I wanted to associate all .txt files to Notepad2. I did an Open With and Choose Default Program. I browsed to and selected Notepad2 and clicked OK. But, the application didn't show up as an option in the Open with dialog box.

I moved the Notepad2 directory to Program Files (x86) and tried again, same problem.

share|improve this question
    
Not an actual answer but Notepad++ could do the job and has a menu just for this (Settings > Preferences > File > Association). –  Baztoune Aug 3 '10 at 15:35
    
I'm having this problem with any application that doesn't have an installer. That I put in Program Files manually (for example, Reflector for opening .dll files). –  Anthony Mastrean Aug 3 '10 at 16:00

3 Answers 3

You can try creating a persistent context entry in windows right-click menu:

  1. first of all backup you registry --> http://windows.microsoft.com/en-US/windows7/Back-up-the-registry
  2. in registry editor go to HKEY_CLASSES_ROOT\*\shell
  3. right click on 'shell' container and crate a new key called (i.e.) "Open with Notepad2" w/o quotes
  4. now right click on the newly crated key and crate a new key called Command (it will be nested in "Open with Notepad2"
  5. select the key 'command' and in the right pane double click on the 'Default' value and enter:

    fullpath_of_notepad2.exe %1

NOTE: use the real full path of notepad2 in place of "fullpath_of_notepad2.exe" and remember that if you move the executable the context menu will stop working.

I have tried this with some apps w/o install (i.e portable apps).

As an alternative (I did not tried it but is freeware) you can try Default Programs Editor which have a more friendly and complete functionality for managing file associations.

share|improve this answer
    
+1 for Default Programs Editor, it is an excellent program :) –  Factor Mystic Aug 4 '10 at 1:05
up vote 1 down vote accepted

I put the application in a folder under my user account and the association dialog works correctly. For example

C:\Users\anthony\Downloads\Notepad2

share|improve this answer

Notepad2 Installer!

For this specific case only

Flo has released an installer that replaces the default Notepad with Notepad2.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.