Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Google Chrome installation on Snow Leopard is asking for access to the keychain any time I go to a site with login information... This happened really suddenly - I've restarted and tried different combinations of settings (always allow) to no avail. The suggestions here: Safari keeps asking permission to access the keychain. have not solved my problem. Any advice?

share|improve this question
add comment

7 Answers 7

up vote 6 down vote accepted

Google screwed up the application signing in their update procedure. I'm just randomly guess they switched the OS X binary over to something like what they were doing with the Windows version (a decompiling, then patching procedure, then recompiling) without considering the possibility of differing hashes.

Mac OS X 10.5 Leopard includes a new code signing security feature that helps verify the integrity of an application. Applications are signed by their creators before being distributed using their private key, and then can be verified on the customer’s machine using the company’s public key.

Mac OS X’s Keychain Services leverage this new code signing feature to verify the signature of each application before allowing access to the contents of the keychain. By verifying the signature, the Mac OS X keychain Services can detect when a potentially malicious change has been made to an application and thereby protect your sensitive data by denying the changed application access.

src: http://help.agile.ws/1Password3/invalid_code_signature.html

As for the fix? Not quite sure. I've just been hammering on Always Allow. I still get them sometimes but ever since I've started hammering, I've been getting less. Eventually, it'll go away if you keep doing that.

Hey, looking back at my guess, try reinstalling.

share|improve this answer
    
this is happening to me again, a year later. boo Google :( –  dorkitude Sep 22 '11 at 18:17
1  
[one year later] - Is this some kind of Groundhog Day? From A to Z, I had to click Always Allow for all the stored sites... –  brasofilo Jan 2 '13 at 10:50
add comment

This is what worked for me. Apple Snow Leopard and Google Chrome 17.0.963.56.

  1. Quit Chrome
  2. Open Utilities: Keychain Access
  3. Search for Chrome
  4. Delete "Chrome Safe Storage"
  5. Start up Chrome. Note that Chrome Safe Storage is back in the list.
  6. Go to a site which requires a password stored in the Keychain. The Keychain dialog box will pop up and ask for your password. Type the password (like you normally do).
share|improve this answer
    
Worked! Looked like my sync now isn't working but I will research that.. –  Marcus Jun 23 '12 at 15:10
    
My problem wasn't that it asked for passwords for new sites but that I had to click through a whole bunch of "do you want to..." when starting Chrome. Solution was to delete the entry in Keychain access and then restart Chrome. I have to reenter all passwords now but that is only fair - if I tell my users to do it I should be able to do it myself too. –  LosManos Jun 16 at 7:22
add comment

Re-installing fixed the problem for me.

share|improve this answer
add comment

What fixed it for me is moving the Google Chrome keychain entry from a secondary keychain into my primary keychain. I have multiple keychains due to poorly moving my keychain database from system to system and moving it into the "master", or "primary", database fixed the issue.

share|improve this answer
add comment

In Keychain Access menu, try to run Keychain First Aid, it ask password and select Verify and start. If found error, try it again and select Repair.

share|improve this answer
    
No errors were found. –  分かりますか Aug 3 '10 at 17:24
add comment

The fix to both Google Chrome and Chromium should be rolling out this week:

http://code.google.com/p/chromium/issues/detail?id=108238#c61

...and there was much rejoicing!

share|improve this answer
    
Nope, 1 year later and still happening. –  Simon Jun 6 '13 at 10:21
add comment

This might be caused by Chrome trying to access credentials saved by Safari. The solution in a short version:

  1. Go to Keychain Access
  2. Delete the entry "facebook.com (password not saved)" or something similar (in my computer it appears with a blue icon)
  3. Done
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.