Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I finally hooked up two monitors to my Ubuntu box but at a time I can only get one to work. It always shows one as disabled even though I have it connected.

How do I get both monitors to work at same time?

This is what the settings look like:

enter image description here

share|improve this question
The image in question seems to be broken - but it is visible at URL – Miro A. Aug 4 '10 at 2:19
up vote 0 down vote accepted

First you should enable Twinview (Configure -> Twinview -> Ok). After that you should be able to detect the other screen by clicking Detect Displays and set up your config.

share|improve this answer
sadly when I click configure only one option is enabled (Separate X Screen). Other two (Disabled and TwiView) are disabled and I can not select them.. – Omnipresent Aug 4 '10 at 2:25
You have to click on the disabled monitor first. After that you should be able to enable twinview. You can't deactivate your only active monitor ;) – Wolph Aug 5 '10 at 2:22

You have to enable it first. Click "Configure", "TwinView", then OK. Set a resolution, drag the screen around, then your monitor will be enabled.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.