Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows 7 computer and make on NTFS driver folder that I like to share. Inside this folder I've made NTFS symlink from one directory to another. Then I'v shared this folder and mounted as folder under Ubuntu. Linked folders looks empty.

Full description what I've done:

  • On Windows server:

    • Created folder "D:\share", inside make folders "share\dev\css" and "share\static\"
    • create symlink with mklink /D from "share\dev\css" to "share\static\css"
    • command dir inside directory "D:\share\static\css\" shows me all files I expect to see here
    • shared "D:\share\" as "dev-share"
  • On Ubuntu (or OSX):

    • mounted "smb://IP/dev-share/" but "static/css" is empty

I think that is Windows share settings problem, so as I dont found answer in Google may be you know how to turn on symlink in shared folders?

share|improve this question

1 Answer 1

in /etc/samba/smb.conf add this to the global section

follow symlinks = yes wide links = yes unix extensions = no

then restart samba

sudo /etc/init.d/samba restart

share|improve this answer
    
pete, thank you for replay, but its not Linux samba client problem, samba server this time is Windows server. I need to find smb.conf analog in Windows 7. –  Mikhail Kashkin Aug 4 '10 at 14:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.