Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Text files (.txt) are not opening. Instead, they are printing as the default command when I double-click on any file.

I realized that the print command is default now and open is not the default command.

How do i change it back?

share|improve this question
up vote 26 down vote accepted

Open up a folder and then go to the menu:

Tools > Folder Options > File Types

Go down to the TXT extension and then click the Advanced button for the Edit File Type dialog:

Edit File Type dialog

If you are missing the open action

To create a new open action, take the following steps:

  1. Click New. A New Action dialog will pop up
  2. For Action, enter open
  3. For Application used to perform action, enter "C:\WINDOWS\system32\NOTEPAD.EXE %1"
  4. Click OK

New Action dialog

(Adjust the program file path as necessary if you prefer opening with another text editor.)

In the Edit File Type dialog:

  • Select open under the Actions list
  • Click Set Default
  • Click OK
  • Close out the Folder Options

This should now set back the default action of double-clicking on a .txt to open instead of printing.

share|improve this answer
Actually the open command was not there, but i created it with similar settings of print command and set it default and its working now – Rishi Aug 3 '09 at 10:27
Edit the answer to contain the filepath and other settings and i will accept it – Rishi Aug 3 '09 at 10:28

You cloud try to right-click on it in a Windows explorer and check if the popup menu entry "right click on it" is there.

If it is, you should then be able to select a program, use Notepad and select "always use this".

open with dialog

Otherwise, there are some ways to restore default association in Windows XP

share|improve this answer
The problem is that the .txt files are printing by default and not opening up as they used to/should. It isn't about being opened up by a different program. – random Aug 2 '09 at 10:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .