Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Within Mail.app on my Gmail account, deleting or moving items no longer removes that item from the Inbox; instead they appear greyed out.

My inbox in Mail.app

In the image above these emails have either been moved automatically to archive directories by rules or deleted by me.

This only started happening recently. I'm using Gmail with IMAP. I've checked through the settings and can't see what I'm doing wrong. Any suggestions would be appreciated.

share|improve this question
    
Have you deleted them entirely, from the server as well? –  random Aug 2 '09 at 8:40
    
No, but ideally I wouldn't want to. In honesty it's the moved emails that are the biggest problem. Most of my emails get automatically moved to specific folders, and while they do exist in those folders they also exist as greyed out emails in the Inbox. –  baxter Aug 2 '09 at 9:41
    
Am I correct to assume that the target folder for these automatically moved messages is a local folder (not an IMAP "folder" on the Gmail server)? Otherwise I would not have expected the messages to be marked as deleted in the Inbox. –  Arjan Aug 2 '09 at 20:25
    
No, I use IMAP folders/labels. I was also surprised that these were considered "deleted". –  baxter Aug 3 '09 at 6:51

4 Answers 4

up vote 5 down vote accepted

Since you're using IMAP, it's possible these deleted messages are being shown, when they should not be.

From the menu, choose ViewHide Deleted Messages, or press + L on your keyboard.

That should do the trick.

share|improve this answer
1  
I use [Command] + [L] a lot in Safari and it seems likely I would have pressed this inadvertently in Mail without realising! Thanks :) –  baxter Aug 2 '09 at 16:36

Gmail is very special when it comes to IMAP. Gmail uses labels, not folders, and there is simply no one-to-one mapping to IMAP. For example: putting a message in the Trash actually kind of assigns the label "Deleted". When labeled as such, any other label for that same message no longer applies.

Be sure to understand the implications of this. Like if you think you copied a message to some IMAP folder, then actually Gmail will only have assigned an additional label to the very same message. Now, if you've (wrongly) set up Mail to move deleted messages to the Trash, then after "deletion" of either of the two occurrences of that single message, the other is removed as well.

So, if your rules move messages to specific folders on the Gmail server, then beware! When moving to a local folder on your Mac, then deleting from the Gmail server may not harm you.

To get the full picture when using IMAP for Gmail, one should unfortunately at least read all of the following from Google's help:

Finally, see Google Labs Advanced IMAP Controls, which allows you to set When a message is deleted from the last visible IMAP folder: Move the message to the Gmail Trash.

And while we're at the subject of Gmail:

  • The Gmail SMTP server automatically moves a copy to your Sent Items. So, when using that server, be sure to set up Mail.app to Use only this server. If you don't, then when Mail falls back to another server, you won't have a copy in your Sent Items.
  • If you want to use another Sender address, then see Adding a custom 'From' address; if you don't then Gmail will change it into your gmail.com address. For fine tuning see this week's new feature Send mail from another address without "on behalf of".
  • Be sure to create a backup. If messages are somehow deleted form either your computer or Gmail's servers, then after the first IMAP synchronisation they're removed everywhere. When using Time Machine: first activate Mail and then enter Time Machine. This will give you the galaxy and star field with, instead of the default Finder, the Mail interface. Here you can even restore message from accounts you've deleted altogether.

Too bad there's no automatic set up, despite of the fact that Mail knows you're using Gmail, indicated by For support, visit Gmail Help Center in Mail's preferences:

alt text

share|improve this answer

Seen this before. Click on the account under Inbox then do Mailbox -> Rebuild and it should move those. If you have a lot of accounts you can rebuild for all of them by exiting from Mail.app, delete "/Users/YOURNAME/Library/Mail/Envelope Index". When you restart Mail.app, it should rebuild all of your folders.

This is sort of a quick fix, though. Don't know what causes it.

share|improve this answer

Another reason for this to happen is that Mail.app has lost knowledge of your Trash folder on IMAP. To fix this, select the IMAP folder you want to use as Trash in the sidebar, then in the menu bar select Mailbox > User this mailbox for > Trash.

The greyed out messages will now start moving to the folder/mailbox you had selected. You may need to do the same for Drafts and Sent messages.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.