Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I do not have the necessary permissions to install anything in var, opt etc. and so have Google Chrome installed in my user folder.

I wish to install Flash Debug, however I can't find anywhere that I have permissions to put the plugin that Chrome will find. Is it possible to tell it where to look? I have tried $chrome_dir/opt/google/chrome/plugins but it is not showing up in about:plugins.

share|improve this question

Note that it does make a difference if you are using a 32bit or 64bit OS. There is no 64bit debugger for Linux (thanks Adobe!!) so to get it to run you have to do something like the following script. I've taken this from sites online so I'm not sure who the original author is. There are some credits listed. I take no credit myself

Basically, AFAIK, Chrome will use the plugin from Firefox. This script will remove anything that is existing, install the dependencies such as nspluginwrapper (to make the 32 bit plugin work on 64 bit) and ia32-libs which are also necessary, then redownload the debugger plugin and install it

I think now that Chrome bundles Flash Player you have to go into about:plugins and disable the integrated debugger. See here for more info on that:

# Script  created by
# Romeo-Adrian Cioaba
# Super minor updates by jason.melton[at]gmail[dot]com
# Released under GPL  

echo "Stopping any Firefox that might be running"
sudo killall -9 firefox  

echo "Removing any other flash plugin previously installed:"
sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
sudo rm -f /usr/lib/mozilla/plugins/*flash*
sudo rm -f ~/.mozilla/plugins/*flash*
sudo rm -f /usr/lib/firefox/plugins/*flash*
sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
sudo rm -rfd /usr/lib/nspluginwrapper  

echo "Installing ia32-libs and nspluginwrapper"
sudo apt-get install ia32-libs nspluginwrapper  

echo "Getting libs"
sudo getlibs -p libcurl3
sudo getlibs -p libnss3-1d
sudo getlibs -p libnspr4-0d  

echo "Installing Flash Player 10"
cd /tmp
tar zxvf flashplayer_10_plugin_debug.tar.gz
sudo cp /usr/lib/mozilla/plugins/
sudo chmod +rx /usr/lib/mozilla/plugins/
sudo nspluginwrapper -i /usr/lib/mozilla/plugins/  

echo "Linking the libraries so Firefox can find it."
sudo ln -sf /usr/lib/nspluginwrapper/plugins/ /usr/lib/mozilla/plugins/
sudo ln -sf /usr/lib/nspluginwrapper/plugins/ /usr/lib/firefox-addons/plugins/  

echo "Done :-)"
share|improve this answer
Amazing! Works like a charm on Ubuntu for both Chrome and Firefox. Thank you! – Maxim Kachurovskiy Nov 19 '11 at 2:12
+1 this answer should be accepted. I had found other instructions but they missed the ia32-libs step, withoutwhich nspluginwrapper will fail – anstosa Feb 5 '13 at 0:57
This is amazing. But the only question is, how to update flash to version 11? I tried with wget‌​_debug.tar.gz but it doesn't seem to work. :/ – HackCode Dec 14 '15 at 14:56
This answer is over 4 years old. Flash is on like version 20 now. Adobe doesn't support it on Linux themselves anymore so I'm not sure what the last supported version is. Chrome has a bundled version that is up to date. Not sure about Firefox anymore. – Collin Peters Dec 14 '15 at 19:45

Chrome (I'm using chromium) picks up plugins from the ~/.mozilla/plugins directory so you can just add there.

You can then go into Preferences->Under The Hood->Content Settings->Plugins->Disable Individual Plugins. You should see '2 files' next to the flash plugin, and if you expand the details you can disable the non-debug flash player.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.