Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't login into Ubuntu after the latest software update. The update froze right at the end and it wouldn't let me do anything.

I force rebooted it and now I get a black screen and when I switch to ctr + alt + f2 terminal, it prompts me to log in.

When I enter my username and password I get the following message:

Welcome to Ubuntu!

Unable to cd to '/home/myusername'

Then it prompts me to log in again in an endless loop.

I logged into root and I'm able to type startx to get the gnome GUI.

Half of the system menus don't work for example I tried clicking on Users & Groups and give me the following error:

"the configuration could not be loaded"

I tried to go to the update manager again but it didn't detect any new updates.... so I'm not sure if they got installed correctly in the first place.

Anyone have any clue?

I'm running this through root in recovery mode since I can't log in with my own username:

ls -l /home
total 8
drwxr-xr-x 38 usrname usrname 4096 2010-08-04 13:01 usrname
drwxr-xr-x 2 foo foo 4096 2010-08-04 12:53 foo

If it helps, I'm able to log in as root in recovery mode, I'm also able to cd /home/usrname plus read/write to it as well.

Just for some reason it won't let me do anything with any other user, even if I create a new account.

share|improve this question
    
Unable to cd to '/home/myusername' looks bad (I fear a corrupted filesystem, perhaps due to a hardware failure). What does ls -l /home show? (Obfuscate user names if you want, but otherwise leave all error messages, punctuation, etc. unchanged) –  Gilles Aug 4 '10 at 17:46
    
I'm thinking the same thing, is there any way to repair system file errors? (I'll also edit my post with your requested information.) –  Tek Aug 4 '10 at 18:15
    
Now that I think about it, take into consideration that I'm able to log into root just not ANY other user for some reason. I get "Unable to cd to '/home/anyusername'" except root. –  Tek Aug 4 '10 at 18:25
add comment

1 Answer 1

up vote 1 down vote accepted

Well, I can't really give myself credit. Today I had a very kind samaritan troubleshoot via SSH for hours from the #ubuntu irc channel at irc freenode.

As highly knowledgeable as he was it surprised that a person that knew so much could be stumped!

Anyway, I am very thankful to him and in his behalf I'm posting the solution to the problem.

Turns out my update completed but had a retarded spasm and messed up the /lib folder permissions along with all the files within it.

Root could run /bin/bash while other users could not. Once the permission problem was fixed everything worked normally.

Thank you all for taking the time to read this anyway!

Maybe it's a bug and this will help someone else figure out how to solve it!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.