Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a system running debian that won't boot after a kernel upgrade. I've tried several things on the system to get it to skip steps to boot, to no avail.

I'm running a live CD on it now, and I want to know where to look to see what was going on in the boot sequence on the hard drive. For what and where do I look?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

The place to look for what happened in the failed boot is in /var/log/syslog, and possibly other files in /var/log. However this only works if the logging service (syslogd) had a chance to start. In your other question, you mention an hwclock-related freeze, and hwclock is first executed before syslogd, so maybe no logs were written.

The boot and shutdown scripts are in /etc/init.d. Which ones are executed and when depends on symbolic links in /etc/rc?.d. First the system boot scripts linked from /etc/rcS.d are executed, then the ones in /etc/rc2.d, and the number after the S in the name of the symbolic link determines the order in which the scripts are executed. If your system uses Upstart, scripts in /etc/init are also executed, in an order determined from dependency declarations.

If your system freezes when setting the clock, chances are that you need to add --directisa or some other obscure option on the hwclock command line somewhere in /etc/init*/hwclock*.

share|improve this answer
    
I added --directisa and tried some other things. No luck. Reinstalled :( –  user13743 Aug 5 '10 at 15:33

Well, I'd start with /var/log/messages on the drive that's having problems (not the one created by your live CD).

If grub is running you should be able to choose the old kernel on bootup ... assuming you did keep it around that is.

You could probably copy the live CD's kernel back to your HD system - though I'd save that as a remedy of last resort because the kernel may or may not be the real issue.

share|improve this answer
    
Old kernel has the same problem :( –  user13743 Aug 4 '10 at 18:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.