Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Can anyone help with me configure my dual-screen monitors for rotation? I have xrandr 1.1. Have tried various approaches, nothing takes. I can't even get the xrandr options to show up in KDE's Display control panel. Thanks1

My lspci output:

03:00.0 VGA compatible controller: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]

My current xorg.conf (works, minus screen rotation):

# Xorg configuration created by system-config-display

Section "ServerLayout"
        Identifier     "Multihead layout"
        Screen      0  "aticonfig-Screen[0]" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        Option      "Xinerama" "off"
        Option      "Clone" "on"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "Monitor"

 ### Comment all HorizSync and VertSync values to use DDC:
        Identifier   "Monitor1"
        VendorName   "Monitor Vendor"
        ModelName    "Dell 2407WFP (Digital)"
        HorizSync    30.0 - 83.0
        VertRefresh  56.0 - 76.0
        Option      "dpms"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "vesa"
EndSection

Section "Device"
        Identifier  "Videocard1"
        Driver      "vesa"
        VendorName  "Videocard Vendor"
        BoardName   "ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]"
        BusID       "PCI:3:0:0"
EndSection


Section "Device"
        Identifier  "aticonfig-Device[0]"
        Driver      "fglrx"
        Option      "DesktopSetup" "horizontal"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
EndSection

Section "Screen"
        Identifier "Screen1"
        Device     "Videocard1"
        Monitor    "Monitor1"
        DefaultDepth     16
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1920x1200" "1280x1024" "800x600"
        EndSubSection
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]"
        Device     "aticonfig-Device[0]"
        Monitor    "aticonfig-Monitor[0]"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1920x1200" "1280x1024" "800x600"
        EndSubSection
EndSection
share|improve this question
    
are you using fglrx? and what distro/version? –  sml Aug 5 '10 at 6:02
    
yes, fglrx. rhel5: Linux <hostname> 2.6.18-53.1.14.el5 #1 i686 athlon i386 GNU/Linux –  user35997 Aug 5 '10 at 21:54
    
i've read conflicting reports that fglrx will / will not work with xrandr; do i need to switch to a different driver...? –  user35997 Aug 5 '10 at 21:55
add comment

2 Answers

Switch to the default open-source driver. It has 3D acceleration for your card, and plays well with xrandr.

share|improve this answer
    
can you point me to that driver? installation instructions, etc? thanks –  user35997 Aug 6 '10 at 1:24
    
Sorry, no. I don't use rhel. –  sml Aug 6 '10 at 3:46
add comment

fglrx currently don't play well with xrandr. you have two safe choices:

  1. Radeon proprietary driver comes with a control center known as Catalyst Control Center (ccc), It has options for rotating screens. The settings are straightforward so try to play with them first before removing the drivers. On my Xubuntu ccc it's located in Menu > Settings.

  2. Remove the proprietary drivers and install the open source drivers. (They are very stable, perfect 2D acceleration, 3D is still improving). Refer to this wiki for info on removing the fglrx and installing open source drivers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.