Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had Windows Vista and it got a virus. I reinstalled the operating system but with XP. Now it works absolutely fine, but every time I try to open a .exe file, i'm told 'the filename directory name syntax is incorrect'

share|improve this question

I had a virus a few months ago and after I deleted the virus I couldn't run any exe files. I thought this was a nice touch by the virus writer. Anyway, there is a web site that has registry tweaks and one of the tweaks restores the ability to run exe files. Sometimes a virus will also disable the ability to process registry files too but the site has instructions for fixing this.

http://www.dougknox.com/xp/file_assoc.htm

Look for:

(Restore default association for EXE files)

share|improve this answer

I'm betting you reinstalled the OS without removing the old one, thus corrupting the registry. Since you just reinstalled, I suggest you back up your data, format the hard disk, then reinstall XP one more time.

share|improve this answer

The registry might still be corrupted from the previous installation somehow.

HKCR\exefile\shell\open\command should have a default value of "%1" %*

If you can't run regedit.exe, try making a copy and renaming it to regedit.com or regedit.bat. File extensions don't matter for executable files.

share|improve this answer
    
Renaming it to regedit.bat will fail MISERABLY. It could, in theory corrupt your system ever further, as a matter of fact. – Hello71 Aug 5 '10 at 2:06

See "Let me fix it myself"

http://support.microsoft.com/kb/950505

Or use this File Association fixer tool http://www.addictivetips.com/windows-tips/fix-windows-7-file-association/

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .