Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a workstation I administer when ever the user opens Firefox or use Google to search for something both think I am in the Netherlands rather than the US. I have checked the location and language settings in both Firefox and Windows 7 and both are set correctly for US and English. This oddity started at the same time the user picked up "My Security Shield" malware which I was able to remove. Currently both Antivirus and malware scans show the system as clean. Would like to avoid a reinstalling the OS if I can so any help would be appreciated.

share|improve this question
    
This has started happening for me too. I'm in the UK and this happens on two separate computers and across browsers, so is unlikely to be software. I suspect Google's geoip location data is wrong for the IP, though I have no idea where you can update that. –  George Jan 7 at 12:22

1 Answer 1

First thing to check: is Google using some cached user preferences which have changed?

If Google isn't setting the language based on a user preference, there are other ways it could be guessing the preferred language.

Web browsers send an Accept-Language header string as part of the request, and if 'nl' is listed first, like this:

Accept-Language:    nl,en-us;q=0.7,en;q=0.3

then Google will display a Dutch page.

I know you said you checked this in your question, but are you certain that the Firefox language preferences (Tools -> Options -> Content -> Languages) don't list Dutch [nl] among the options?

You can test what headers the browser is sending by visiting http://www.xhaus.com/headers

The other possibility is that the PC has been assigned (by the ISP) an IP address which appears to be in the Netherlands, or that web requests are being routed through some external proxy (hosted outside the US) which you're not aware of.

Try visiting http://www.geoiptool.com/ and see where it thinks you are.

share|improve this answer
    
I checked out the header and the en-us wsa the only language listed and the geoiptool came back a showing me in correctly in New Jersey. Bing search does seem to work correctly so it must be some setting common to both Firefox and Google. –  Chris M Aug 6 '10 at 13:28
    
I forgot to mention thanks for the link to both of those great tools. –  Chris M Aug 6 '10 at 13:52
    
So if you click Search Settings (or Zoekinstellingen) in the top-right corner, and select "Engels" from the drop-down, then "Vookeuren opslaan", does that fix things? What URL is shown in the address bar? www.google.com or www.google.nl ? –  njd Aug 6 '10 at 14:39
    
I can change the language and it looks OK but the under lying issue is everything still point to www.google.nl and I can't figure out why? –  Chris M Aug 6 '10 at 15:59
    
Last thing I can think of trying: run Firefox in a completely new profile by closing any existing Firefox windows (and check Task Manager to ensure firefox.exe is gone) then run: "firefox -profile xyz"; alternatively, try disabling extensions by running: "firefox -safe-mode" –  njd Aug 9 '10 at 9:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.