Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Acer Extensa 5220 running Windows 7, and around a month ago it started having problems when attempting to enter sleep mode.

The screen dims to black nicely like it always does, however the laptop will clearly still be running. The fan is still on, and the HDD will still be accessed.

Further, the wireless mysteriously switches off (an LED turns on to indicate it's off). Logging back in, a flip of the wireless switch easily turns it back on.

I'd like to clarify that this doesn't seem to be a case of the laptop going to sleep normally and then waking up instantly (due to e.g. a device waking it up) -- although that might be the case.

Pressing anything on the keyboard turns the screen on instantly, with the character I just pressed showing up on the password input field, further showing it's awake the whole time.

I've tried many fixes, including disabling media sharing and powercfg settings, to no avail. The problem irritates me so much as I have to shutdown the computer every time instead of a quick sleep/wake procedure.

share|improve this question
Th problem seems to be in bad ACPI driver for windows 7. – netme Aug 5 '10 at 13:12
@netme it was working just fine before, as far as I can tell a typical Windows update changed everything. What makes you think it's to do with the ACPI? – Redandwhite Aug 5 '10 at 15:43
I think, that drivers were not written properly. Sometimes with some brands it happens. You have 2 ways: update your drivers to the newest one, or try to reinstall the current version you have. – netme Aug 5 '10 at 18:12

Go to the event viewer (start typing "event" into the start search) and select windows logs->system. You'll see 1000's of events, but track through them and if your system was normal, you'll see events like "system entering sleep mode". Perhaps you'll see something like a sleep mode immediately followed by a wakeup. Or you'll see something like "Can't enter sleep mode". Post back what you find.

share|improve this answer
No mention at all of sleep, but it seems to mention: "The Windows Error Reporting Service service entered the running state." immediately followed by "The Windows Error Reporting Service service entered the stopped state." – Redandwhite Aug 5 '10 at 15:02
if you unplug it, will it eventually sleep? if you tell it to sleep with the power button as opposed to the menu does it do anything different? – Knox Aug 5 '10 at 17:21
Allowing it to run flat does no good. Where it normally puts itself to sleep, this time it tries to, but just ends up in the described state. It just seems unable to enter S3 no matter what, even though powercfg says that S3 is clearly supported. The power button and the menu don't change the behaviour at all. Baffling. – Redandwhite Aug 6 '10 at 14:54
up vote 0 down vote accepted

It turned out that disabling the Hibernate option from power config using the following line worked:

powercfg -h off
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .