Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Mail.app (on Mac OS X 10.6) and when I send an email to users on PC Outlook, with an attached image, they get the email as an image embedded into the body, not as an attachement.

I even tried clicking "view as icon" before sending the attachment from Macmail, but that made no difference. I also tried this myself, sending from Mail.app over to my PC's Outlook, and I do get that same problem. In Outlook the image is not coming through as an attachment, but as an image embedded into the body of the email.

The reason this is an issue primarily is because the user is then unable to click "save as" and has to actually copy and paste it into some other program, which means the file is converted from jpg or png to the bmp format. But beyond that, most of my recipients don't even know how to copy and paste it into another program to save it that way anyway. They need the "save attachment as" functionality.

share|improve this question
    
Find that message in your Mail.app "Sent" folder and do View > Message > Raw Source. Then scroll down to just before the attachment data and see if there's a "Content-Disposition:" MIME header. See whether it says "attachment" or "inline". If it says "attachment", then Mail.app is doing the right thing, and Outlook is doing the wrong thing by inlining it. –  Spiff Aug 5 '10 at 22:00
    
It says "inline". So how do I change that? –  Joel Glovier Aug 6 '10 at 2:22

4 Answers 4

I believe that this is about Outlook, not about Mail. Outlooks is recognizing that there are images and is choosing to display them inline; there's not much you can do about it. (For example, the "view as icon" option is a viewing preference for Mail; it doesn't affect the email's data at all.)

You could enclose all the images in a .zip archive before attaching them. This would certainly force Outlook not to display them inline.

share|improve this answer
    
No - I checked the source as sent from Mail, and it says the attachment is inline. –  Joel Glovier Aug 12 '10 at 13:02
    
(as suggested by Spiff in the comment on the question) –  Joel Glovier Aug 12 '10 at 13:02
    
Unfortunately, this doesn't seem to work for me! If I send inline, it appears inline in Outlook and keeps getting sent back to me in the recipients' replies as part of the original quoted text, thus cluttering up my mailbox with repeated attachment pics. If I send it as 'view as icon'. It appears as an inline icon in Outlook and not as a downloadable full sized pic file. Please help! –  user204333 Mar 5 '13 at 13:32

In Mail.app under the Edit menu there's an Attachments submenu. What items are checked off? I recommend putting a checkmark beside "Always Send Windows-friendly Attachments". (See the middle option in the screenshot below).

If you choose Always Insert Attachments at End of Message, the attachments will always be put at the end of the message and not where you dragged and dropped them. It should only matter if Outlook users are missing the text after the first attachment as Outlook can regard the rest of the email as just HTML attachments. This option shouldn't have an effect on your problem and you can ignore it in the screenshot.

Attachments

(Image Source: My blog)

share|improve this answer
    
Actually that option is checked. –  Joel Glovier Aug 5 '10 at 19:42
    
@JAG2007 - I think that by "checking off" Chealion means uncheck this option, although the screenshot shows it checked on. –  AdamV Aug 7 '10 at 6:53
    
@AdamV: By default it's unchecked (or used to be by default). You can try having it always inser the attachments at the end of the message but then you won't have any ability to inline the attachments. –  Chealion Aug 7 '10 at 15:57
    
Sorry, but I still don't know if you use "checking off" to mean "click the check so it is turned off" or "put a check against it, like chenking an item off on a shopping list". And I have never used Mail.app so I have no idea if it normally on, off, or what the end effect will be of changing this. I'm just trying to find some clarity for everyone's benefit, as I think you may have the right answer here if only I could tell. –  AdamV Aug 11 '10 at 7:49
    
@AdamV: Fixed. Sorry. By default it is off. –  Chealion Aug 11 '10 at 15:11

Does this still happen if you send your email as plain text instead of rich text?

Check the Format menu or Preferences -> Composing.

I am assuming that inline images would only be possible with rich text encoding, but with no access to Windows, I have no way to check.

share|improve this answer
    
I need to send rich text emails, so if so I'll have to live with it I guess. –  Joel Glovier Aug 12 '10 at 12:57

Its a "feature" from Apple mail. You can bypass this by using mail attachments iconizer http://lokiware.info/Mail-Attachments-Iconizer

share|improve this answer
    
Not interested in using 3rd party plugins, but thanks anyway. –  Joel Glovier Aug 16 '10 at 15:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.