Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having a problem setting up home group. My home sever pc (win7 Home Premium) connects directly to the internet, I shared it's internet connection to one of its ethernet (lan) cards which is then plugged directly into the WAN port on my wifi router using a cross-over network cable. All the computers (win7) in the house connects to the wifi router and can access the internet fine and see each other in windows Home Group, but none of them can see my home server pc. please help.

update: could it be a router setting?

share|improve this question
    
Is there a reason you don't have them all connected to the router and the internet being run directly to the router? –  JNK Aug 5 '10 at 18:39
    
yes, i have a wireless "broadband" internet connection which works via a small usb device plugged into my server pc. unfortunately the usb device cannot be plugged into the router –  Daniel Brink Aug 5 '10 at 18:42
add comment

1 Answer 1

up vote 0 down vote accepted

It could be this -

  1. You server gets its IP address from your ISP.
  2. The wifi router is providing private IP addresses to the computers connected to it.
  3. The wifi router is probably doing NAT.

If this is the case, then you server is on a different network than the rest of the home computers. Essentially it is just another computer on the internet.

Please check the ip addresses of the server and of the computers connecting via the wifi, if they are in different ranges then that is the problem.

I think you should be able to connect the server to the wifi router in the same way as the computers in the home network.

Please let us know about the IP address ranges.

share|improve this answer
    
the wifi router is running as a DHCP, so the computers connected to it do indeed have different ip range than the server. trying your alternate connection idea now, will let you know in a minute if it worked –  Daniel Brink Aug 5 '10 at 19:14
    
no luck. it did not work –  Daniel Brink Aug 5 '10 at 19:23
    
the ip ranges are vastly different 192.168.. vs 41... –  Daniel Brink Aug 5 '10 at 19:24
    
Your server might have more than one ip address now. Does more than one adapter show up on the server? –  bryan Aug 5 '10 at 19:28
    
i'm running a fit-pc2i as a the server, its a bit confusing as its got 2 Ethernet adapters and a wifi adapter and then my wireless broadband usb device creates a fake Ethernet adapter and a broadband connection adapter, all a have different ip addresses on different ranges, so I disabled the one unused Ethernet apter and WiFi adapter –  Daniel Brink Aug 5 '10 at 19:34
show 6 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.