Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I'm on the road, I occasionally VNC to my wife's home computer (Win-XP). I do this by having her start up a PuTTY ssh session which establishes a reverse-tunnel for VNC and SSH and connecting back via VNC and/or SSH through the tunnel.

It often happens that if I move or attempt to minimize the PuTTY window while I'm connected back via VNC that the VNC session will hang. Any reverse SSH session will also hang.

When this happens, I'm dead in the water unless I can get in touch with my wife and she's near the computer.

It's almost as if manipulating the PuTTY window causes PuTTY to stop transferring network data. Does anyone know if this is a known problem with PuTTY and if there is a fix or other work-around?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

I've not seen this specifically, but there is a possibly related puTTY problem with VNC. If a SSH session in VNC ends unexpectedly, so the window becomes disabled rather then closes as it would on a normal termination, it seems to cause VNC to spin scanning for updates but not sending anything out.

I tunnel in via SSH though, rather than using a reverse tunnel - perhaps you could try this? If you setup Cygwin's SSH server on that machine and enable port 22 to be directed to it from your router you can SSH in rather than SSHing out so can reconnect if the previous SSH channel dies. When a dead puTTY session is causing VNC to lock, I can always still restart the VNC session. It locks again for screen updates once the screen is fully displayed in the VNC client but it still takes in input, so I can click where puTTY's window close button is, close the VNC connection again, and when I reconnect to VNC the errant puTTY window is gone and all else is working as it should be.

From the way I read your question, SSHing in will remove the need to use puTTY at the remote end of the tunnel anyway - if you are only using puTTY to manage the tunnel then that has now been replaced by Cygwin's OpenSSH (server end) and what-ever client (probably puTTY again) you call in using.

If SSHing in to the XP machine is not an option for what-ever reason, you could still try the client side or OpenSSH (via cygwin or some other port), using that for the call out to build the reverse tunnel instead of using puTTY. You could also try playing with the polling options in the VNC server settings but I don't remember this making any difference with the problem I've seen.

I think puTTY handles its window in non-standard (or at least generally unexpected) ways, as a number of window management utilities (like those which add snap-to-grid, or enhancements to the window decorations, and so forth) have an explicit exception for puTTY by default.

FYI: the places I've noticed VNC+puTTY issues are also machines running XP - though I don't think it will be XP specific, I've just not been in a situation where the problem as I understand it (some incompatibility between what puTTY does with itself and how VNC operates) would arise on other Windows versions. In all cases I'm using the TightVNC variant of VNC, both server and client.

share|improve this answer
    
+1 for updating my router to allow inwards SSH. I already allow this to another machine at home. I don't know why I didn't think of it! Perhaps because I was afraid to expose a Windows box to the internet, even if it was only the SSH port. –  Adrian Pronk Aug 8 '10 at 22:46
    
If the existing machine that you can connect to from the public Internet by SSH can see the Widnows box, then you could SSH into that and port-forward for VNC to the Windows machine from there. This will save both the extra software install (unless you want cygwin on the XP box for some of the many other useful things it offers) and making an extra machine publicly addressable. This is how I connect to my home XP machine remotely. –  David Spillett Aug 9 '10 at 10:12
add comment

Putty Tunnels option is not working on Windows 7 64bit. It always hand up the connection.

Putty + Tunnel + MSTSC.

share|improve this answer
    
The OP doesn't mention Windows 7. The original question was asked and answered back in 2010. If you have a problem with PuTTy I suggest you search newer questions/answers or start your own question. –  HaydnWVN Dec 10 '12 at 11:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.