Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an issue with an old laptop I'm trying to fix up. It has an issue with the wireless.

Here are some of the things I know or have tried:

  • Repair option in network settings results in "Unable to renew IP address. "
  • Disabling/re-enabling the connection does nothing.
  • The router is a Verizon Actiontec model.
  • Resetting the router does nothing.
  • [ipconfig /flushdns], [ipconfig /renew] and [ipconfig /release] have no effect.
  • [ipconfig /renew] results in a "Unable to contact DHCP server" error message.
  • The DCHP Client service is running and set to automatic start.
  • My IP address is 169.254.x.x, which, from what I've read, means it can't find a DHCP server.
  • I have tried the following commands to reset the TCP/IP stack and rebooted afterwards:
    [netsh int ip reset reset.log]
    [netsh winsock reset catalog]
  • Other laptops can connect to the wireless network fine.
  • The machine is Windows XP SP3.
  • There are no firewalls that I know of on the machine.
  • The laptop picks up Wi-Fi points just fine, but when attempting to connect, takes an unusually long time to get past "waiting for network to be ready. " That leads into "Acquiring network address" which takes a long time before that, too, fails.
  • It connects fine via Ethernet.

I'm honestly stumped. This laptop can't connect to the wireless internet and I'm not sure why. Anything else I can try?

share|improve this question

4 Answers 4

up vote 1 down vote accepted

Good news, the wireless works now.

Apparently, the problem was that my girlfriend gave me the wrong password. After a password change and a reboot, the wireless works great.

This is the fault of the Windows XP wireless networking software for simply giving me "Limited or no connectivity" instead of saying the password was wrong. I don't know why it wouldn't report an invalid password.

share|improve this answer

Just a thought: Have you disabled the DHCP server in the router? It seems that Windows was unable to get an IP address, and therefor chose something from the APIPA range.

Can you try another Wireless card? Can you revert any settings in the card to their factory defaults?

share|improve this answer
    
Other laptops can connect to the router fine. I don't have any other wireless cards to try and I'm unaware of any settings for this current one. –  Corey Aug 5 '10 at 22:27

I wonder if you have same problem with other wireless networks or just this network? well,try to uninstall and then install the driver(wireless card) if it works out.

share|improve this answer
    
It's a problem on all networks. –  Corey Aug 5 '10 at 22:26
    
then have a go on un/install wireless Card Driver, when you run ipconfig /all, what are written for DHCP server & Default Gateway? –  user44509 Aug 5 '10 at 22:36

Does the router have "MAC filtering" enabled? That is a list of network devices that are authorized to connect to the router.

If that's not it, download a free tool called Wireshark. Use it to capture the traffic going through the wireless card on the laptop. If the connection is being rejected, you should see the reason (or perhaps an error code) in the log that it creates.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.