Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a gigabyte UDR5 with 12GB Ram, and i7 920. The os runs of 2 x 80GB x25 SSDs in raid0 (mobo software raid) and I have 4 x 320GB raid5 for storage (2 year old drives). Running windows 7 Ultimate x64

In the last 2 or 3 weeks my PC started freezing randomly, recently every 20 minutes or so. The screen freezes, yet I can still move the mouse, but all the windows are frozen. I tested the RAM, unplugged everything except the keyboard + monitors... nothing helped.

I unplugged the drives I have in raid5... and the freezing stopped. I then deleted the array, and left the drives as separate disks, all are visible in windows.... and I had no freezing problems. Remade the RAID5 array.... it was stable for 2 days, and then the problems started once more. Deleted the array, everything is normal again.

Im inclined towards the drives being bad, but then why do they work fine when not raided?

My OS array, on the same mobo, works flawlessly.... so Im confused.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

I'm going on a limb here, but perhaps the RAID controller is fried? I would suggest booting a Ubuntu Live CD and doing some heavy I/O operations.

The trouble is, that this won't really teach you anything. The only way to eliminate the possibility of one or more bad disks is to eliminate them one by one from the configuration. Try setting up a RAID 1/0 or 0/1 and using them in pairs until you find the culprit.

Alternatively, you can remove the array and check the SMART records of the disk.

share|improve this answer
1  
Seems like thats the case. Put in 2 drives in raid1. Left overnight, frozen by morning. Connected the other 2 drives. Same story. So unless there are 2 bad drives, looks like the raid controller is screwed. –  user11955 Aug 10 '10 at 22:21
    
I had a fried RAID controller on an Asus motherboard a few years ago. Disabling RAID worked fine; I settled for that. –  Paul Lammertsma Aug 12 '10 at 1:09

Perhaps the raid process causes the OS to access a bad sector on one of the drives. Try running a disk analysis tool that checks the entire drive, and run it on all 4 drives. Does it find any bad sectors?

share|improve this answer
    
I'd recomend this too. I used to have 2 drives on my old XP machine and it would work fine for a week and then would get just like you described it. I ran the Seagate tools (it's a bootable CD) and the drive that wasn't my OS since if I unplugged it it would work and it would find all this bad sectors and would be fine for a while. –  Hondalex Aug 6 '10 at 14:08

I am not sure I understand your RAID5 setup, but if this is a hardware RAID5, you might update the driver to the latest version downloaded from the manufacturer's website.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.