Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't know if anyone else has experienced this so just thought I'd find out if it's a known issue or if it's just happening to me. since I first got my 3GS, I've had it synced with Micorsoft Exchange (initially 2003, now 2008).

If I go into my contacts on the phone and add a new contact it immediately syncs back at my Exchange server and vice versa. However, sometimes if I add a contact via one of the 'quick links' (Like if I get a text from someone not already in my Contacts on the phone, then use the facility to create a contact for this number), while the contact is visible on the iPhone, it 'never' makes it to the Exchange server.

Does this happen to anyone else?

share|improve this question

closed as off topic by Wuffers, nhinkle Mar 7 '12 at 5:29

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
are you saving the contacts you create on the SIM card or on the phone's memory? –  Rex Oct 28 '10 at 13:03

1 Answer 1

I had this problem also; the solution is pretty simple. On your iPhone, go to "Settings > Mail, Contacts, Calendars" and scroll down to the Contacts section. Change the "Default Account" setting from "On My iPhone" to your Exchange server. This will ensure that contacts created from an e-mail or a text message are synced to Exchange.

share|improve this answer
    
I don't have a 'Default Account' setting under Mail, Contacts, Calendars > Contacts. I just have a 'Sort Order', 'Display Order' and 'Import SIM Contacts' options there. I'm on iOS 4.01 on an iPhone 4 if that helps? –  marcusstarnes Nov 24 '10 at 10:42
    
A method to enable the "Default Account" option from goo.gl/1o9Lm 1) In iTunes, on the Info tab for your iPhone, check the box next to "Sync Address Book contacts" (using a Mac—PC may be different) WARNING: If you don't use the Address Book on your computer, continue. If you do use your Address Book, all of those contacts will probably be added to your iPhone in addition to whatever is already there. If you are ok with this, continue. 2) Sync iTunes with your iPhone 3) "Default Account" should now appear under contact settings. 4) Uncheck "Sync Address Book contacts" in iTunes. –  Joshua Perkins Nov 24 '10 at 14:29
    
This solution was specific to Google Sync, but I don't see any reason for it not to work for any Exchange account. –  Joshua Perkins Nov 24 '10 at 14:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.